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Chapter 1

General Information

1.1 About this Book

This documentation serves as a reference of the Cenon functions. One chapter de-
scribes in short how to work with Cenon by example. This alone makes the book
thick enough. Additional dokumentation for the modules and special tutorials for the
different applications of Cenon are planned.

Depending on your computer system (Linux, Apple), there are differences in the look
of the user interface. To avoid bitterness, this book is available for both interfaces, so
everyone whether using Linux or Apple should be happy. The text is identical in both
variants of the book, just the images show the prefered and known user interface.

The various computer systems (Linux, Apple, OpenStep) also show some differences
in the directory structure. This information is always given for all systems.

This book was created using LyX on Linux. The colored title page and the slip case
were created with Cenon.

All trade marks like PostScript, Adobe Illustrator, HPGL, DXF, Gerber, Excellon,
Sieb&Meyer etc. belong to the respective owners.
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10 CHAPTER 1. GENERAL INFORMATION

1.2 The history of Cenon

Cenon has been started in late 1992 / early 1993 as a
production software under NextStep/OpenStep. Since then, Cenon has made lots of
friends all over the world and is still making more.

Besides the usual improvements of a software project, the features of OpenEnd (Vec-
tor graphics conversion), and CenonPCB (prototyping of printed circuit boards) were
merged into Cenon. Additionally basic font editor functions were added from a
started project.

In the year 2002, Cenon was completely redesigned with a modular concept. This
makes Cenon expandable by modules for extremely different graphical applications.
The first modules available are a CAM module and an Astrology module. Two ap-
plications from opposite sides of the spectrum.

From 2000 till the end of 2002, Cenon was ported to GNUstep (Linux and Co) as
well as the new Apple operating system (Mac-OS X). Also, most other Unix systems
are supported. Cenon is now at home on all important systems.

During the conversion of Cenon towards free software, we also converted the As-
trology program, which was started in 1998 for our own research. The Astrology
module is available for free.

The whole basis of Cenon with its incredible feature set, including vector graphics
conversion, design, publishing etc. is available as Free Software since 2003. Only
the CAM module for manufacturing on CNC machines is available as a commercial
application. This ensures the professional support, which is needed in this area.
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1.3 What can you do with Cenon

Cenon is a modular graphical software. In it’s basic version Cenon is most at home in
the area of DTP. The concept of Cenon is a mixture of construction and publishing.
This makes it very convenient and intuitive to work with.

With the powerful import functions of Cenon, you can import and edit almost all
graphics formats (PostScript, HPGL, DXF, ...). The design functions fulfill all com-
mon Publishing demands. The output possibilities mirrors the import and aims to
give limitless productivity to the user.

Moduls for Cenon offer extensions of the functionallity. The first module was the
CAM module (or the CAM version of Cenon), which is available as a commercial
plug-in. This turns Cenon into what it always was - a production software for output
on engraving machines, or milling maschines, plotters and cutting plotters. The CAM
version of Cenon has its application in the industrial area as well as in sign-making
and model-making.

This user guide for Cenon doesn’t describe the features of modules. For a description
of the functions of a module, please refer to the corresponding document.

1.3.1 Cenon

Key Features

e Import of PostScript, Adobe Illustrator (AI3), DXF, HPGL, Gerber, Excellon,
Sieb&Meyer, Type 1 fonts, ...

Import of scanned images (TIFF, GIF, JPG ...)

Import of ASCII data for mass production

complete set of editing functions for lines, curves, arcs, complex paths, poly-
lines, text, threads, sinkings, etc.

comfortable management of layers and pages
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DTP functions like clipping of images and color separation

Text along paths

Color shading (graduate, radial and axial)

vectorisation of raster images

Rich Text (vector fonts (Type 1, TTF), tabulators, rotation, ...)

Easy and intuitive operating for fast and accurate working.

Export of PostScript (PS, EPS), HPGL, DIN, Gerber (RS274X) and more
Font editing of Type-1 fonts (not very comfortable yet)

Extensible via additional modules (Plug-Ins)

Examples of applications

Desktop Publishing (DTP) - Creation of Folders, stationary, logos, advertis-
ings, ...

mousepads, business cards, book marks, cd labels, ...

vector graphic conversion, including postprocessing of all import and export
formats in every direction.

Conversion for documentation: Conversion of construction data from DXF to
PostScript, or conversion of PCB data from gerber to PostScript.

Letters - texts of all kinds using text masks for flexible, fast or preformatted
writing

Font-Editor for Typel fonts (not very comfortable, but it works)

many many more
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1.4 Moduls for Cenon

This section describes some of the available moduls for Cenon. With the aid of
modules Cenon can be transformed into a entirely different program.

141 CAM Modul

The CAM module is an optional commercial module respective complete commercial
package.

CAM was the first application of Cenon. That is how Cenon started. Since 1993
this important application of Cenon has been continual enhanced and improved. To-
day, Cenon is at home in almost all areas of CAM. From engraving of name plates,
signmaking, to industrial serial production reaches the base of installations world
wide.

(model created with Cenon)

Key Features

e automatic tool radius correction to inside or outside
e Pick Out function for high precision engraving

e Relief function on raster images for production of three-dimesional relief im-
ages
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e Drills, threads, sinkings

e Stepwise processing of dipping depth in flexible steps
e optional settlement

e Webs to support parts during manufacturing

e selektive processing

e Precise interactive positioning of machine

e Teach-In

e Tool management

e Output on HPGL- and DIN-66025 compatible devices

e expaned User Guide

Examples of applications

e Sign making (Milling, engraving, cutting of any kind of advertisings)

e Engraving (door signs, goblets, coining dies, ...)

e Industrial engraving (type plates, labels, signs ...)

e Electronic (front panels, switch boards, prototypes of printed circuit boards ...)
e Model Making (models of buildings, industrial appliances ...)

e Fine Machanics

e Cutting of sandblast foils or cutting of foils for polishing optical glasses

e Production of individual operation panels

e Cutting the contour of single CDs
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e Production of dashboards

e you name it

1.4.2 Astrologie Modul

The Astrology module is an optional module which is available as Free Software.

This extension for Cenon is completely breaking the line. It turns Cenon into a rich
and simple to use Astrology tool. With this module, Cenon demonstrates in a very
special und unusual way it’s flexibility and it’s capacity for metamorphosis.

The Astrology module has been started in the process of research on Fractal Geom-
etry, and of course was motivated by enthusiasm for this fascinating subject. Thus,
this module like Cenon in general was programmed with a lot of dedication.

An entire chapter of the book "Astrology with Cenon" covers the fractal-physical
background of Astrology. The book is available in PDF format for free from the
Cenon site.
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Key Features

e Creation of event and birth charts

e Management of event data

e Vis-a-vis display of two events in a synergy chart
e Astrological geographic charts

e Aspect table including ecliptical mirrors

e Display of exactness of aspects in three shades

e Planetary nodes

e Output to printer and plotter (HPGL)

e High precision of displayed graphics

e Flexible and themeable masks for charts and maps
e Free editing of charts

e Precision features like a topocentric degree scale

e Additional book "Astrology with Cenon"

1.4.3 PCB Modul

A planned module for Cenon, which has not even been started.

There is the idea to provide the part library of Platon for Cenon and add some ad-
ditional features to make Cenon an easy to use PCB layout tool. Platon was a nice
and powerful PCB Layout system (including circuit diagrams) for Atari-ST and later
NextStep, but never made the step towards OpenStep/GNUstep/Apple. The know-
how is still there.
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1.5 The world around Cenon

This chapter displays some services and products around Cenon.

1.5.1 Folder and printed book

If you want to save yourself from printing this manual and you feel the need to hold
something more real in your hand than software, then you are welcome to order
the beautiful and practical slip case of Cenon including the book. A CD with the
complete everything is also included. You can order the books in the online shop of
vhf interservice.
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http://www.cenon.info

1.5.2 Tutorials for Cenon

We are in the process of writing tutorials for Cenon, which will describe working
with Cenon on step by step examples. Cenon is not exactly a small programm and
not every trick might be obvious at once. The tutorials are available as PDF for free,
but you can also order a hard copy in the online shop of vhf interservice.

The following tutorials are readily available or at least planned:

e The Cenon User’s Guide

Astrology with Cenon (Astrology module)

e CAM-User’s Guide (CAM module)

Cenon - Tips and Tricks

Vektor graphics conversion with Cenon

PCB prototyping with Cenon (CAM module)

e Editing Fonts with Cenon

http://www.cenon.info

1.5.3 CAM-Version

Cenon is available as a commercial CAM version (including CAM module) with
guaranty and full support. The CAM version turns Cenon into a flexible production
tool.

http://www.Cenon.biz
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1.5.4 Engravingsystems and Routingsystems

vhf camfacture offers engraving- and milling machines, which work perfectly with
Cenon and make lots of fun, if you like really hand-screwed applications.

All vhf systems offer 3 full axes, which can be positioned independently. Therefore
the machines are ideal for engraving as well as drilling and milling. The precision of
1/100 mm grants for exact results.

The modular construction of the machine allows assembly for your special require-
ment, and keeping future extensions open. Even existing machines can be extended
with vhf components.

Take a look at the web site (http://www.vhf.de) or contact vhf camfacture
directly.

1.6 Installation

The installation process for Linux, Apple and OpenStep differs slightly. Please read
the section of your System.

Here we describe the installation of the executable packages only. If you want (or
need) to compile Cenon yourself, take a look at the file INSTALL inside the source
tree.

1.6.1 Installation on Linux

1. log in as user root

2. Insert the Cenon-CD and mount the CD. Then change to the directory of Cenon
for Linux (Linux > Packages). If you downloaded Cenon, you can skip this
step.

3. You will find a RPM package. Install it with the installation tool of your Linux
distribution, or enter the following command in a terminal shell:


http://www.vhf.de
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repm —Uhv Cenon*.rpm

To start Cenon go to the folder /usr/GNUstep/Local/Applications and start
Cenon with a double click. If you don’t habe GWorkspace running you can
start Cenon by typing ’openapp Cenon’ from a shell.

If you are using the CAM version of Cenon and it is your first installation,
Cenon will ask you for a license key.

1.6.2 Installation on Apple (Mac OS X)

1.

Insert the Cenon-CD and wait until the CD-Symbol appears in the Finder.
Then click on the CD-Symbol and select the path of Cenon for Apple (Apple >
Packages). If you downloaded Cenon, you have to unarchive the downloaded
file instead (double click).

You will find a package with the name Cenon-x.x.x.pkg, where x stands for the
version number. Double click the package to start the installation.

. The installer appears, where you have to authorize yourself as administrator.

Then you can start the installation process by confirming the different stages
(Introduction, Read Me etc.). The files are now extracted from the file and
copied to your hard disk. This takes a few moments.

. If you have a previous version of Cenon already installed, the install programm

will notify you. Just continue the installation.

After the package is installed, you can start Cenon. To do this, go to the direc-
tory ’/Applications’ and start Cenon with a double click.

If you are using the CAM version of Cenon and have installed Cenon the first
time, the license panel appears. Here you can license the program, or you can
run Cenon in demo mode.
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7. Your CNC controller usually has a serial interface to be connected to the com-
puter. Since newer Apple computers doesn’t provide a serial interface, you
need an USB adaptor - usually this is a adaptor from Keyspan:

http://www.keyspan.com

Install your Keyspan adapter and the driver software as given in the adaptor
documentation. To be sure that everything works, you can use the ’Serial As-
sistant’ coming with your Keyspan adaptor.

If you have problems, you can check the device entry (#DEV) in the Cenon
device configuration (Kapitel ??). The device entry must be equal to the de-
vice created by the USB adaptor (/dev/tty.USA...). The devices in the Cenon
configuration provide a wildcard ’*’ to allow automatic device expansion.

Tip: If it happens that the serial device hangs (e.g. no device is connected),
than you can unplug the USB adaptor to regain access. You can use the
cu device instead of the tty device to avoid the hanging of the device and
Cenon in this case.

8. To come into the pleasure of importing PostScript or PDF files, you have to
install GhostScript. You can get a version of GhostScript from the same place
where you got Cenon, but any other version of GhostScript will do the job.
Double click on the GhostScript package to start the installation.

1.6.3 Installation on OpenStep

1. Log in as user root

2. Insert the Cenon-CD and wait until the CD-Symbol appears in the File Viewer.
Then click on the CD-Symbol and select the path of Cenon for OpenStep
(OpenStep > Packages). If you downloaded Cenon, you have to unarchive the
downloaded file instead (usually a double click should work).

3. You will find two packages, which you have to double click one after the other.
The names are:


http://www.keyspan.com
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(a) Cenon.pkg
(b) CenonLibrary.pkg

. For each package a window will appear, where you have to click on Install.

. Then another window appears. Just click on Install or press Enter. The files

are now extracted from the file and copied to the hard disk. This takes a few
moments.

If you have an old version of Cenon already installed the install programm will
notify you. Just continue the installation.

. Wait until the first package has been finished before installing the next one.

. After all packages are installed start Cenon as user root. To do this, go to the

directory ’/LocalApps’ and start Cenon.app with a double click.

If you have installed the CAM version of Cenon for the first time, the license
panel appears. Here you can license the program (See the next section) or
decide to run it in demo mode.

1.7 Initial Operation

You will find Cenon in the application folder. Double click on the Cenon.app to start
Cenon.

To get the Cenon-Icon into the dock, you can simply drag the Icon from the applica-
tion folder and drop it on the dock.
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Now, you can start Cenon, by clicking the Cenon-dragon in the dock.

In the library folder of Cenon you will find some examples: The folder 'Projects’
keeps some nice Cenon projects. The folder 'Jobs’ has CAM examples, and the
folder ’Examples’ provides examples of import formats.

The library of Cenon resides in slightly different places, depending on your system:

OpenStep: /LocalLibrary/Cenon
Apple: /Library/Cenon

GNUstep: /usr/GNUstep/Local/Library/Cenon

1.8 Support

User Guide We try to keep the user guide practical and full of information. The
user guide should answer most of your question.
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You can find information about new versions and an up-to-date FAQ
(frequently asked questions) on our Website:
http://www.cenon.info.

In the mailing list of Cenon, you can ask questions and exchange your-
self with other users of Cenon (at the time this book is written, the
mailing list has not been installed).

direct support for the free software is only offered via e-mail.

If you need custom support, you can purchase the DTP package or an
other version of Cenon with support. Besides Userguide, Slipcase and
CD, you will get a reasonable amount of support via eMail. Please
try to check out all other possibilities (User guide, FAQ, mailing list)
before you write an e-mail asking for support. Support time slows
down the development.

vhf camfacture offers in depth support for the CAM-Version of Cenon
and the CAM-Modul.

If you find a bug, we are thankful to receive your bug-report or even
better a patch. We will try to fix serious bugs for the next release.

1.9 The file-extension and icons

% Icon for the Cenon-project. The file extension is: .cenon, (.cen)

Extension and icons of import-formats

‘-'ﬁj Icon for HPGL-files. The extension is: .hgl, .hpgl, .plt


http://www.cenon.info
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A Icon for DXF-files. The extension is: . dxf
. [

Icon for Adobe Illustrator files. The extension is: .ai

This is the icon for PostScript files. The look of the icon might differ
somewhat from system to system. The possible extensions are: .eps, .ps

I
7 e This is the icon for PDF-files. The look of the icon might differ somewhat
from system to system. The extension is: .pdf

Gerher

This is the icon for Gerber-files. The possible extensions are: .gerber, .ger

a The icon for DIN-files like Excellon or Sieb&Meyer. The possible exten-
sions are: .din, .drl
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Chapter 2

Publishing with Cenon

In this chapter we use the example of a cover page to describe all the steps necessary
to create a Cenon document. Although we use a publishing example here, everything
applies equally to other applications of Cenon. The other chapters of this book serve
as reference of the Cenon functions. For further special description and examples of
how to use Cenon, we refer to the other Cenon documents.

The general proceedings when creating a Cenon document is as follows.

1. Creating a new document; Import of a Graphic; Loading an existing project
mask

2. Creating of new layers for the separate working steps
3. Editing of the project (document)

4. Export and Output

To get a mental picture of our work before starting - as every artist has, we now take
a short look at the final result. That’s how our document will look like, when we are
through this tutorial:

27
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2.1 Create a new Document

2.1.1 Preparations

Before we start, we can set some preferences.

Cenon Preferences

You can reach the Preferences Panel by the menu Info > Preferences.

Here you can choose the unit of measurement (mm, Zoll, Point). We select mm for
our example.

Additionally it seems useful for DTP applications to disable the selection of non
editable layers.

Important for our work is to set the snap-to-point distance. 2 pixel should be well.

Further information on the preferences can be find in section 3.1.
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2.1.2 New Document

In the menu Dokument with the menu entry New (Alt-n), you can create a new Cenon
document. What we get is an empty document window with the title "Untitled".

UNTITLED12 — ~fTempo

% [71.4917 | ¥ [61.3695 | Width:[ 514517 | Height [0 13595 | [n =
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The crosshairs don’t have use for us at this place. We simply move them to the lower
left corner of the window, so that we get the coordinates 0/0 displayed for them inside
the Inspector Panel.

The crosshairs are the origin of our coordinates. They can be moved to any desired
position from where the coordinates should be measured or the grid should start.
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2.1.3 Set working area

As we want to print our cover page on a DIN-A4 paper, we set the working area of
the document window to this format. To do this, we open the Working Area Panel
via the menu Format> Working Area or by using the keyboard shortcut Alt-A.

Working Area

Width:| 204

J—ieightlega.sa

The format A4 has a width of 209 mm and a height of 296.86 mm. We simply enter
these values into the text fields and press Enter on our keyboard.

2.1.4 Save Document

To have the document created permanently, we save it to a file and give the file the
desired name. Cenon documents on disk get the extension ’.cenon’. That’s how they
are identified.

To save the document we open the save panel via the menu Document> Save (key-
board shortcut: Alt-s)
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Here we can go to the desired folder and provide the filename inside the text field
called Name. We call our document CoverCAM.cenon. By pressing OK, the docu-
ment will be saved.

2.1.5 Grid

To make the positioning of our graphic objects easier, we can activate a background
grid. All graphic objects will then snap to this grid.

To create the grid, we have to open the Grid Panel via the menu Format > Grid or the
keyboard shortcut Alt-Shift-#.
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First, we better choose the same measurement unit like our coordinates - mm. This
avoids confusion. Then we enter the grid distance into the text field. In the example
we use a grid distance of 5 mm. By pressing the Set button, the grid will be created
and displayed with gray lines.

To activate and deactivate the grid during work, we can now simply use the key Alt-#
or the menu Format > Grid.

2.2 Create Layers

To have a better overview and more flexibility, we can organize our graphic elements
on several layers. For example, we can place large areas building the background
of our document, on their own layer. To concentrate on other objects, we then can
simply disable this layer.
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Inspector

To create a new layer, we need the layer inspector. We get it from the menu Tools
using the menu entry Inspector, and then inside the Inspector, clicking on the right-
most icon in the top icon bar. Alternatively, we can simply use the keyboard shortcut
Alt-5. To have this work, our graphic window has to be in the foreground!

A new layer will be created with the button New. The layer appears with the name
UNTITLED and has to be renamed to the desired name. The layer will be placed to
the lowest position in the layer list. You can move it to any position inside the list
with the mouse (while pressing the Control-Key on your keyboard).

We create the following layers for our document:

Background A layer for the background elements. A layer like this makes sense,
so we can’t accidently select the background while editing in a high
zoom, probably without even realizing. We now simply turn the layer
not editable to avoid this problem.



2.3. GET TO BUSINESS - THE DESIGN 35

Cenon Here we place the main elements of our cover page. Those which are
not language dependant.

Text Deutsch This is our layer for German Text.

Text English Here we place the English version of our text. This way we can man-
age all desired languages without efforts in one single document.

Images This is the layer for our images. An extra layer for images allows
editing without bothering about other graphic objects.

Help Help lines and guides are placed here. This layer will be disabled for
printing as it only serves to simplify our work.

Further information about the layer inspector can be found in section 3.6.19.

2.3 Get to business - the Design

2.3.1 Help layer

On the help layer we place supporting details, which we don’t need afterwards on
our print. Beside help lines (guides), these could be things which show our cover
page as it would appear as complete handbook. As the background of the book will
be filled over size, we also draw a frame which shows the real end size of the cover

page.

& 7 First, we turn on the help layer, and turn off all other layers. This can be
achieved simply by clicking on the eyes inside the layer inspector. An open eye
displayes the layer. To be able to edit on the layer, the pencil has to be intact.
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Now we create the frame of the cover page in the desired size. We select a
discreet color for the rectangle, for example gray. The origin of the frame should be
placed to even coordinate without decimals, this makes things easier.

We lock the position of the frame, so we can’t move it accidantly, later. This is done
in the ractangle inspector (Alt-1) with the switch Lock.

The edges of the frame will be used, in the following design process to snap our
objects. So, they are guides too.

To give our cover page the look of a real book on screen, we draw wire rings and
punch holes. This helps visualizing the final results.

Tip: If you happened to draw on a wrong layer and now want to move the
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object to the right layer, you can do the following:

e select the object (both layers have to be visible and editable)
e choose the destination layer from the layer inspector

e click on "Move to layer" to finally move the object

2.3.2 Background

Now we start with the background. We turn on the background layer and turn off the
other layers (not visivle or at least not editable). The help layer should remain visible
to allow snapping to the grid.

On this layer we place the cutting marks and other markings, which need to be
printed. If we have many markings, we could use a layer of it’s own for the markings,
of course.

Last but not least, we place our background image here. In our case a polished
aluminum surface. The image should have a sufficient height resolution. About 600
dpi should be enough. The image can be provided in almost any format.
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To get the image into our document, we have several choices. We can drag it directly
from the Workspace (or the Finder on Apple) into our document. We can import the
image via the menu Document > Import, as well.

We now scale the image to the desired size. If it is much larger than the window, we
use the Transform Panel to bring it down to a reasonable size first. We find the panel
in the menu 7ools > Transform Panel (shortcut: Alt-F).
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In the pop up menu on top of the panel we select Scale. Now, we scale by keeping the
aspect ratio of the image (Uniform scale) to say 80% of the original size. If we have
the image completely inside our working area, we can do the rest using the mouse:

First, we grab the lower/left corner of the (deselected!) image and drag it to the outer
edge of our help frame. There the position will snap in.

In the second step, we grab the upper/right corner. This time while keeping the
Control key (Ctrl) on the keyboard pressed. Resizing the image this way, will keep
its natural aspect ratio. We snap to the corresponding edge of our frame.

If we have mastered the background, we turn the layer to non editable (broken pen-
cil).

Tip: We should save our work from time to time. Whenever a working step
is finished we could even save under a different name, this way keeping
several versions of our work.

More information on the Transform Panel can be found in section 3.7.

2.3.3 Cenon

Now, after all the preparation, we can get to the real design of the title image. First,
we turn on the corresponding layer (we have called Cenon), so that the layer is visible
and editable.
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Inspector

Triangles

We start with the two blue triangles (to be exact, our triangles have four edges). The
triangles are paths, which are composited from lines. The lines are then joined and
filled.

First, the upper triangle...
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We need the Line tool to draw the lines. We find it in the Tool Bar (menu 7ools >
Tools...), and activate it with a click by the mouse.

Tool X|
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We draw the lines with the mouse. We first click at the start position of the line
and then at the end position of the line. If we don’t snap to another object, the next
line segment is started automatically. We draw the complete train of lines and end it
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exactly where we started.

Tip: To avoid starting a new line every time we have ended a line, we can
draw the train of lines roughly to the side of the help lines. If we have
completed the train of lines, we can easily drag the line ends with the
mouse to their exact position on the help lines.

k

If the lines are drawn, we leave the line mode and go back to the arrow.

To create a path from the lines, we have to select all the lines, which are part of the
deal. As we don’t have any other lines on the layer, we have easy play: We simply
select one single line and go to the menu and select Edit> Select equal (shortcut:
Alt-e). Now, all lines are selected. To join them, we select Edit>Join from the menu
(shortcut: Alt-j). Now, if we don’t have selected too much, we get a closed path.

Now, even inside the path we can move the edge points of our path easily to the
desired position.

Now, we make a copy of the first path to create the second triangle. After selecting
the path, we use the keyboard and press Alt-c followed by Alt-v. Now we have two
triangles. If you don’t like your keyboard, you can also use the menu to copy the
path. Use Edit> Copy (Alt-c) and Edit> Paste (Alt-v) to do this.

We mirror the new triangle with Edit > Mirror (Alt-m) and are almost done. We move
the whole thing with the mouse to the lower right corner of our guides. Be aware, that
before you grab the corner of the triangle, the triangle has to be deselected (without
knobs)! Then, we move the triangle to the help frame that the two corners snap
together.

Finally, we drag the upper two edges of the "triangle" to the tips of the upper "trian-
gle" - ready!
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Now we make color: To do so, we select the two triangles and select the fill button
in the Inspector (shortcut: Alt-3). In the pop up menu we select Graduated. Now the
triangles are black, but we will manage to give them a nicer color.
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To slect a color, we clock on the border of the upper Color Well in the Inspector
panel. The Color Panel will open up.

We want a beautyful dark blue. Then we do the same with the lower color well and
give it a bright blue with much green, so that we get the color of a blue sky.
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To make the graduation smoother on our print out, we set the step width to a finer
level. Three pixel should do well.

Now we want to rotate the color graduation of the lower triangle. To do this, we
select the upper triangle with the mouse, while keeping the Shift-Key pressed. This
deselects the upper triangle! Then we set the Graduate Angle to 180 degree.

More information on the Fill Inspector can be found in section 3.6.17.
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To use a graphic of the complexity of the dragon, we should have a separate document
to create it in all silence. When we are ready with the design and have set all the color
shades as needed, then we grab it into our document. If not a separate document, a
separate layer would be sufficient too. But we have the dragon ready for ages now
and simply copy or import it to the place where it is needed.

We already covered the import of graphics, so now we open the dragon in a second
document, select what we need, and copy it with Alt-c / Alt-v into our document.
Here it is! The first time it needs some time to render the many color shadings in
the background, but from then on the rendering goes fast. What follows is a well
known procedure, scaling (Transform Panel), 90 degree rotation (Alt-r), moving (for
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example with the mouse), mirror (Alt-m) - and Voila.

Logo

The same thing with the Cenon logo - we copy it into our document. The internet
address (www.cenon.info) is standing in small letters below the logo. We will do this
little text by hand, now.

Text

We start by activating the text tool. With a click by the mouse at the desired
position on our document, a text box pops up at this position and wait for our input.
On top of the document window a text ruler will be displayed, which gives us pow-
erful functions for alignment, tabulators etc. We set the text of the internet address to
right alignment.

‘EEI CoverCAM.cenon — ~iT empo ]

Now we select the entire written text and open the Font Panel to set the font size. We
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get the panel via the menu Format > Font > Font Panel (Alt-t). Here we set the desired
font and size and press the Set button.
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We leave the text mode and go back to the arrow. Then we select the newly
created text box with a single mouse click.

Within the Fill Inspector (Alt-3) we give the text the correct color. Then we move
the text to its position under the logo.

To get the text box aligned exactly to the right of the logo, we now use the Transform
Panel. So we do the finger trick Alt-F (or Tools > Transform Panel). In the pop up
menu at the top of the panel we select Align.
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The graphic objects which we want to align must be selected. As the logo already
sits at its place, we only want to align the text in relation to the logo. So we first
select the logo! Then we select the text while keeping the Shift-Key pressed. Doing
this we ensure that the logo will not be moved, only the text. The first selected object
serves as the reference for the align function.

If we now press the right button inside the panel, the text will be aligned to fit under
the logo on the right side. Try it!

If everything fits perfectly, we group logo and text togerther, so they can’t escape any
more. We simply select both objects and choose Edit> Group from the menu. We
can also use the shortcut Alt-g from the keyboard.
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2.3.4 Text

Now off to the text layers. If you remember, we have created a text layer for each
language. This way we only need one document for all languages.

We fill one text layer after the other with text. First we turn on the text layer we want
to edit (visible and editable). All the other layers should be at least not editable.
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We already know how to place text. So, select the text tool from the Tool Bar, create
a text box, write the text, set the font and the font size.

This time we don’t set the font size for the entire text box. Instead we set the font for
the selected region of the text, only. The text region can be selected with the mouse.
A whole word is selected by a double click, and a whole paragraph can be selected
with a triple click. We select the region "Version 3.60", because this text needs to be
a little smaller. We select the size for this region as usual from the Font Panel. The
line height can be adjusted using the ruler on top of the document window.

If size and line height are correct, we move the text to its position, do corrections if
needed, and we are ready with our text.

The same play follows for all the other languages we know. But, here we take the
easy way and simply copy and change the text box to the other layers. That’s a
known procedure with Alt-c and Alt-v. It is important here, that the destination layer
is editable before you paste with Alt-v and that none other layer has priority and
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steals your text away.

2.3.5 Images

Now the best of all, freeing images from the background. First we turn of all other
layers - just the image layer and us. Now we can peel our machine from the back-
ground without disturbance. Before we start, we have to drag the image into our
document and scale it to reasonable size to fit in the window.
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We have the image in the document? Well, lets give it a nice name using the Inspec-
tor. We also select a format to compress the image on disk. The correct scaling of
the image doesn’t matter for now. First we have to get rid of the background.

We start by buckling up the image, so it has no chance to slip away. This can be done
in the Inspector by activating the Lock switch. We already know this button.

Now we start placing a path exactly around our image, which resembles the contour
of our freed object.
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Tip: To jump from the tools of the Tool Bar into the arrow mode without large
mouse movements, we can simply press the Alt key. As long as the key
is pressed we are in the arrow mode, able to to move Objects instead of
generating them.

.
a We start with the straight segments of the path, which we can simply bridge
using lines. We select the line tool and on we go. If our track makes a smooth turn,
we end the line with a double click on the mouse. Then we start a new line where
further lines are needed. It is easier to draw all the lines first, and later add curves in
between. This way we don’t have to change the editing modes.

Now the second run around with the curve tool. The bezier curves are created
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by four clicks with the mouse. The first click sets the starting point of the curve.
We start our curves exactly at the end points of the lines, where they will snap in (to
make this work we have activated the snap to point distance in the preferences). We
set the endpoint of the curve with the second click to the starting point of the next
line - or somewhere in between. A bezier curve shouldn’t be too complicated. More
than 90 degree turns are not recommended. The remaining two clicks set the control
points of the curve.

Don’t forget the open areas inside the image.

If all lines and curves are placed all together present a closed picture without gaps,
where everything is nicely snapped together, then we can gather all parts and create
a path. We already know how to do this from the triangles.

So, we select all lines and curves, which will be used to free the image. We then
select from the menu Edit> Join (or press Alt-j). To select all the parts it is again
enough to select one line and one curve. With Alt-e all the other lines and curves will
be selected, too.
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Don’t forget to save from time to time. That was a good piece of work.

Now, we fill the path to see if everything fits. To do this we go to the Fill Inspector
(Alt-3) and set the pop up to Filled. Now we see, if we have closed accurately all the
subpaths. Are there lines intersecting all of the path, then there was a gap, and Cenon
wasn’t able to close it. In this case we have to split the path with Alt-J and correct
the related segment connections. Then try again.

Now we do the fine tuning of the path, because we want it perfect. Our path should
go exactly along the edge of the object. So we zoom in as deep as it makes sense and
correct the line and curve points until we are satisfied.
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To move the vortices of the path, the path has to be selected. Then you can grab a
vortex and move it.

Tip: If you happen to click beside the path or the vortex, the image will be
selected. However, if you select the image once again while keeping the
Shift key pressed, you can easily deselect it again.

| o
. If a line is missing you can cut the path into two, using the cutting tool. Now
you can add the missing elements and join the parts to one (Alt-j).

Finally, if the path is perfect and ready, we can join it with the image. Select the path
and the image and once again use Edit> Join (or Alt-j). The background is gone!
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Now we make all the other layers visible again, move the image to its place, and
scale it down to the final size. To move the image, we have to unlock it, of course.
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4 little images

Now, only the four little images are missing, then we are through. So, lets start
by placing four rectangles, which will be used later to clip the images from their
background. Just the rectangles without the images for now.



2.3. GET TO BUSINESS - THE DESIGN 59

CoverCAM.cenon — ~fTi empo

User’s Guide

Warsion 3.60

To place the rectangles we select the rectangle tool from the Tool Bar. The
rectangle is placed with the first click. The second click sets the size. The size can
be changed later using the inspector or the mouse, of couse.

We copy the first rectangle three times - or do we need four? This way we can
play and look without producing too much work. Dows a rectangle or a square look
better? You can change the size of all rectangles together in the Inspector. Just select
all rectangles and set the size and height. Be careful with setting the origin this way,
or all your rectangles will be dumped to a pile. Not a big problem, however. Press
Undo (Alt-z) to revert the little accident.

Now the images for the rectangles. They shouldn’t be larger as needed for the print.
Also, not needed parts of the images should be removed in a image processing tool
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(for example Gimp).
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We now move the first image into our Cenon document, give it a nive name and set
the compression format.

We place the image at its position and direct it behind the rectangle, so that the
rectangle is in the foreground and not invisible behind the image. We achieve this
with the menu Format > Move to back (Alt-9), while the image is selected. Now we
scale the image down using the mouse while keeping the control key (Ctrl) pressed,
until it sits correctly inside the rectangle. To accomplish this we grab the image at one
edge and drag this edge to the center of the image until the desired size is achieved.

Finally, if the image is in position, we select image and rectangle and join both by
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pressing Alt-j (or using the corresponding menu entry).
With the other images, we do the same - Ready!
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2.4 Printing / Color separation

Before we start printing, we have to set the paper format for printing. So far we only
set the size of the working area. The format for printing could be different.

Use the menu Format> Page Layout (or Alt-P) to open the Page Layout Panel. We
set the format to the same format as the working area - DIN A4. We press OK to
affirm our change. The resolution of our document, should be 100% for printing.
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To finally get it printing or separate colors, we select Print from the menu (shortcut
Alt-p). The Print Panel appears.

Here we can select the printer (if we have more then one), set the number of pages to
print, set the scaling etc.

2.4.1 Printing

To print, we don’t have to do more than press OK.

If we want to print to file we press Save, instead. A Save Panel appears, which let
us set the directory and file name. By confirming with OK, a PostScript file with the
extension ’ps’ or a PDF file (if your systems allows this) will be written.

2.4.2 Color Separation

To separate colors, we have to set the kind of output to color separation. The color
separation can be printed or saved to file. This will create four distinct files repre-
senting the separate colors (Cyan, Magenta, Yellow, Black). The four files will get

b b

the endings *_c’,’_m’,’_y’, und ’_k’.

For further information on color separation take a look at section 3.13.



Chapter 3

Reference part - the functions of
Cenon

3.1 Preferences settings

You can enter elementary preference settings for Cenon in this dialogue box. You get
there over the menu information, entry basic setting. The preferences are ordered on
several cards, which can be reached by the icons on top of the panel. The available
icons depend on the modules plugged in.

63
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3.1.1 General Preferences

Cenon Preferences

Here you can choose whether the mouse is caught by existing points or not and how
big the distance should be during the editing.

The function helps a lot in precise construction work, as new or moved graphic ob-
jects snap to points of other graphic objects. You can also use this function to create
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your custom help raster (e.g. in the form of a spiral), so that the edited graphic objects
will be attracted by the nodes.

unit

T =4

Here you can set the unit with which all the measures of the program that are not
specially signed are displayed. Some windows, like the graphic window, have their
own pop-up-menu to define/set the unit.

Disable Caching _|

When you don’t want the graphic to be cached - that means that a copy of the entire
document is stored in the background even when only a section is displayed - you
can switch it off here. When you have little memory capacity it can be sensible to
switch of the cache.

Cenan Expert »|

When the expert mode is switched on there are no warning panels before the program
carries out the final/unchangeable function or a function that takes a lot of time.

Remave Backups ¥]

Here you can choose, whether backup files are removed after saving a file or is they
should be kept. Backup files have the same file name with a tilde symbol added to
them, for example: ’Filename.cenon~’

Selection of non editable Iayers_l

If you enable this option, you can select graphic objects, even if the layer is not
editable. This can be useful in selective CAM production.
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3.1.2 Import Preferences

Cenon Preferences

Now we introduce and explain the single parts of this window:

Here you can select a parameter file for the HPGL-import. The parameter-file con-
tains information about the structure of the HPGL-derivative you want to load, so that
Cenon is able to understand the code. For the creation of your own parameter-file or
the adaptation of an existing files please see section 4.4.
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You can select a parameter file for the import of Gerber-files (it’s the same as with
HPGL-files). See also section 4.2.

Here you can set the resolution for the DXF-import. this value isn’t given through the
format, so that it’s possible that different programs use different resolutions for the
output. Please use the same value for the output of the file that your CAD-program
uses. Common values are "25.4” or ’1°. See also section 4.3.

Here you can decide whether you want to transform the curves into arcs for the
PostScript-import or not. The transformation will only be carried out when it is
sensible. You can also enter whether the text should be divided into paths during the
import or not (this is necessary for some Postscript-files to ensure that the display is
not distorted/falsified). See also section 4.5.

Here you can set the device for the DIN Import. This is used to import drill data
in different derivates of the DIN format (Excellon, Sieb&Meyer). If you select the
Default entry, the import tries to detect the format of the file itself. This is the prefered
setting for Excellon and Sieb&Meyer.
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When you switch on this function Cenon will generate an extra layer for each color
automatically when you import a graphic with more than one color. The colors are
distributed correspondingly.

Enabling this functions, all imported graphics is tried to be joined in a filled path.
This usually only works if your data is prepared in a manner suitable for building a
path.

3.1.3 Export Preferences

Cenon Preferences
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If you activate this option text is converted to vectors on export. This ensures that
fonts look like expected and should be if you want to export the data for output on a
device. However, if you want to import the graphic to another program, you probably
want to have this option disabled. The option only applies to export formats which
support text, like PostScript and DXF.

3.2 Import of graphic files

Cenon is able to import the following data formats:

PostScript, Adobe Illustrator 3.0, PDF

e HPGL

e DXF

Gerber

DIN, Excellon, Sieb&Meyer 1000, Sieb&Meyer 3000

Rasterimages (TIFF, GIF, JPG, ...)

Type 1 Fonts im Font Package

When you click on the entry open in the menu document you get a file selection win-
dow. You can load a file that is available in one of the formats mentioned before. The
following file formats are assigned to the following extensions (see also section 1.9):
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PostScript .eps, .ps, .ai
PDF .pdf

DXF .dxf

HPGL .hpgl, .hgl, .plt
Gerber .gerber, .ger
DIN .din, .drl

Fonts font

Raster images | .tiff, .tif, .gif, ...
Cenon Projects | .cenon

After you have left the file selection window with a double-click on the wanted file
or with a click on OK, Cenon loads the file.

Import to existing project

You can also import to a dedicated layer (resp. create new layers) of your current
project by using the Document > Import menu item.

Import to

iselected layer ="
| |

In this pop up menu in the Open Panel, you can select whether you want to import
to the selected layer or create new layers. You probably want to create new layers,
when importing DXF files or drill data.

3.3 The menus of Cenon

In this section we will describe the functions in the order of the entries in the menu.
When you look for a special information about a special entry you can surely find it
here.
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Info

Document

Edit

Display

Format

Tools

Windows

Print

Here you can retrieve some basic setting and information.
Among other things you can retrieve with this menu-item the
online-help.

With the document-menu you can open, save and create a
document, projects and graphics. Additional you can import
ASCII data for mass production. See section 3.3.1.

The edit-menu offers functions to work on the graphic. See
section 3.3.2.

The display-menu offers functions that concern the display
of the graphic. See section 3.3.5.

The format-menu offers functions that concern the layout of
the page and the texts. See section 3.3.3.

In this tool-menu you can find the tool-panels of Cenon. For
example the inspector and the tool-bar. See also section 3.3.4.

The window-menu shows all the graphic windows.

Printing. The printing panel appears, which is also used for
separating colors and writing PostScript into file.
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Hide

Quit

Using this item, you can hide Cenon without having to quit
the programm. With a double click on the application icon
you can reopen Cenon.

With this command you can quit the program.

3.3.1 The Document-Menu

e

Crr—
:

Dpen ...

Import....

Irpart &SCH .

RevertTo Saved .. |

Save

Save As .

Save Output ..

New

Open...

Import...

Import ASCIL...

This command creates a new document.

This command brings up the Open-Panel. Here you can
select the file you want to open. You also select a file
for import here. The extension of the file is used for
identification of the format.

Here you can import all import formats of Cenon to the
current project. The Open-Panel offers you the choice to
import to the selected layer (of the Layer-Inspector sec-
tion 3.6.19]) or create new layers for the imported files.
See Section 3.2

Here you can load an ASCII file. This can be used to
produce different signs of the same geometry in a mass
production.
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The strings which are extracted from this file are dis-
tributed on Text graphics. Before you start to import a
file you have to place these Text objects where they be-
long.

Sort rule:

2| i W |

L[\J;:: character convearsion .n]

In the Open-Panel for the ASCII import you can select
how you want the strings in the file be sorted upon your
Text graphics:

e row by row from the upper/left to lower/right
e row by row from the lower/left to upper/right
e column by column from the upper/left to the lower/right

e column by column from the lower/left to the up-
per/right

e column by column from the upper/right to the lower/left

The file is a simple list of strings separated with a Space
character, Newline, or Tabulator (TAB). If you have space
in your strings you need to place the string inside double
quotes or use TABs to separate your strings (Is a TAB in
your text, TABs are used as the separating character):

text] text2 text3
or
"text 1" "text 2" "text 3"

If you have to insert a Newline or TAB in your strings
you can use '\n’ respective ’\t’ in your text.

"Line 1\nLine 2" "Line 1\nLine 2"
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Tip:

e If the text you want to import is in a different for-
mat, the search/replace function of a common text
editor can help you a lot to change the formatting.

Save This command saves the document with the current name.
If the document is new, the Save-Panel appears (see Save
As).

Save As... The Save-Panel appears. Here you can save your doc-

ument with a new name. Additionally the Save-Panel
offers the possibility to export your file in different for-
mats:

Format

|§Cennnf.cennnj -l]

In this pop-up menu you can select the export format.
Disabled items mean that this entry is not applicable or
not implemented yet.

Cenon Saves the file as Cenon document

PostScript Exports the file as Encapsulated PostScript
(EPS)

Gerber Exports the file in the Extended Ger-
ber format (used for Printed Circuit
Boards)

DXF Exports the file as DXF

HPGL Exports the file as HPGL

Typel Font Exports a previously loaded Typel

font
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Save Output...

Revert to Saved

Here you can save the data in a file instead of sending
the output directly to a machine. The same setting and
starting positions are used (as when you send it directly
to an output-machine).

This command loads the last version of the document.
The changess of the current document are lost then.

3.3.2 The Edit-Menu

Cut

Copy
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Paste

Delete

Undo, Redo

Build Contour...

Join

Split

Punch

Cutting out, copying and inserting (paste) function in the
usual way.

Cut cuts the selected objects from the document and stores
them in the background. Copy copies the selected objects to
the buffer in the background. Paste inserts the stored objects
into the current document.

Tip (Smart Paste): After the first paste of the buffer, you can
move the position of the inserted objects. The next paste will
be inserted at a distance to its predecessor using this offset,
as will all consecutive pastes.

With this command the objects are deleted.

With Undo the last operation is undone. With Redo the un-
done operation is restored.

The Contour-Panel appears. You can generate the contour of
the object here. With this panel you can create the contour of
an object. See section 3.12.

This command unites single objects together in a path. When
you unite the objects you can either select two ending points
and unite them or you can combine many objects to a unit.
When the first selected object is a path all other selected ob-
jects are added to this path.

If you select an image and a closed path object (Path, Circle,
Rectangle, Polyline), then the image is clipped from the path
object. Use this to free an image from its background.

This command splits paths into single objects.

This command removes all hidden areas of all selected and
filled elements. All the hidden areas of all the selected and
filled elements are deleted.
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When the objects have got a different color the elements on
top is punched out of the element below. When the objects
have got the same color they are combined.

Group Here you can group different objects so that you can handle
them easier than single objects.

Ungroup Here you can rollback the grouping. The objects remain in
the twisted or mirrored status in which they were transformed
while they were in the group.

Mirror This command mirrors the selected object.

Rotate 90° This command rotates the selected objects by 90 degrees around
the center of all the selected objects.

Select Equal This command selects all objects that are equal with the ob-
jects that have been selected already.

Select Color This command selects all the objects that have got the same
color like the objects that have been selected already. This
entry in the menu is very practical when the colors of the
imported files are meant to be distributed on different layers.

Select All All the objects of the displayed layers are selected.
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3.3.3 The Format-Menu

Er—

Fuont

I
Text I
G’ti'd. I
Bring ToFront
Send ToBack ).
o
B
F!

Dplimize Moves
Working &rea ... &
Fage Layout. .

Font With this menu you get to the common sub-menu to set
the font. Most entries are only active, if text is beeing
edited.

E—

FontPangl .. t
Unbold {8
Italic i
ndetline
Kerr =
Ligature -
Baseling i
a
4

Copy Font

Faste Font

Here you can:

e call the Font-Panel (Keys: Alt-t) and select a new
font, type or size.

e change the selected text region to bold and back to
normal (Keys: Alt-b)

e set the selected text region to italic and back to nor-
mal (Keys:Alt-i)
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Text

e underline the selected text region and go back to
normal

e change the kerning of the selected text region. The
sub menu allows you to tighten or loosen the kern-
ing, or go back to the default. The kerning deter-
mines the distance of the characters in the text.

e move the base line of the selected text within the
sub menu. The selected text can be raised or low-
ered. Superscript and subscript offer values most
commonly used. Using raise and lower you can
change the base line in finer steps.

e copy and paste the font style of the selected text
region (Tasten: Alt-3 und Alt-4).

With this menu you reach the usual text menu to change
the text parameters. The menu is only active, if you are
editing text.

C—
Align Left
Center -
Align Right
Hicle Ruler
Copy Ruler
Faste Ruler
ConvertTo Pé;th
Bind To Path

4

| — |z |

Here you can:

e align the selected text region. You can align text to
the left (Alt-<), center (Alt—) or right (Alt->).

e toggle the text ruler (Alt-R)
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e copy (Alt-1) and paste (Alt-2) the text ruler to other
positions in your text.

e convert the selected text object into a path object.
This is very useful, if you want to use operations
on a text, which are only possible for path objects.
For example, if you need text with a color shading.

e bind the selected text object on a path object (e.g.
Line, Polyline, Arc, or Curve). See Editing a Textpath
in section 3.11.9.

Grid Here you can set the grid. A grid is used to attract the
mouse pointer to fixed positions, which makes it much
easier to precisly construct.

(o |
Turn Grid Off #
slign toiGrid
et

Have you set the grid, you can switch it off and on with
the top most menu entry. Set opens the Grid-Panel:

Grid |

Di‘staﬂca-.| 10 il -l|

Set

Here you can set the distance between the grid lines. You
can choose the unit of measurement in the pop-up menu.
Press Set to create a grid with the new distance.

Bring to Front
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Send To Back With this menu items you can move objects to the fore-
ground or background. So you can influence the se-
quence of the display. When an object cannot be selected
because it is hidden, you can put on the others with this
command.

The selected graphic object can be send all the way to
the back or front, or just a single graphic object further
to the back or front.

Optimize Moves The moves between working pieces can be optimized.
Therefor the order of the objects is changes like with the
entries obove.

You can display the moves with the Menu Display > Show Moves.
Working Area... The Working-Area panel appears. Here you can enter

the size of the working area. The measuring unit of the
size is taken over from the Preferences-Panel.

Working Area  X|

Width: | 0
He_r%ht | ]

The working area is displayed as white background in-
side the Graphic-Window.

Page Layout... The Page-Layout panel appears. Here you can set the
page format for the printing.
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3.3.4 The Tool-Menu

The tool menu gives access to the different tool-panels of Cenon. Some items appear
only if the respective module is installed.

E—

Tools ...
Cofors ... 5
Irispector ..
Batch Production ... B
Transform Panel .. F
Froject Seftings ...
Intersection Panel .
Data Panel ...
Teach In Panel ...
&stro Fanel .
Tools... The tool-bar appears with which you can switch the editing
mode of Cenon. When you start the program the Tool-Bar is
opened automatically. See section 3.4.
Colors... The Color-Panel appears. You need it to assign another color
to elements of your graphic.
Inspector... The inspector appears. It shows the characteristics of the dif-

Batch Production...

Transform-Panel...

ferent graphic elements and it allows also changes/transformations.
See section 3.6.

The Batch-Production Panel appears. Here you can distribute
the graphic on the working area. See section 3.9.

The Transform-Panel appears. Here you can carry out several
transformations (scale, rotate, align, mix). See section 3.7 for
more information.
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Project-Settings...

Intersection-Panel...

CAM-Panel...

Teach-In Panel...

Astro Panel...

The Project-Settings Panel allows you to set settings and in-
formation (like Author and remarks) for your current project.
See section 3.5 for details.

The Intersection-Panel allows you to set different elements
on intersection points of your current graphic. This can be
useful if you like to distribute large amounts of drill markers
in a grid. See section 3.8 for further details.

The CAM-Panel of the optional CAM module appears. The
CAM-Panel is opened automatically after you have started
the program. It is used for the management of the layers and
tools and to control the machine. See section ??.

The Teach-In panel of the optional CAM module allows the
collection of positions from a machine. You can position a
plotter or machine over a template using the Control-Panel
(section ??). The positions then can be captured into the doc-
ument as a mark via mouse click in the Teach-In Panel.

The collected mark objects can be converted to 2-D or 3-D
lines from within the Teach-In Panel.

This opens the Astrology panel of the optional Astrology
module. A description of the free Astrology module can be
found in the book "Astrology with Cenon".

3.3.5 The Display-Menu

The items of this menu gardly depend on the loaded modules.

Show Directions

Cr—

D

Shiow Moves

I

Show Tool Diameter T
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Show Directions Here you can see the direction of the vectors dis-
played as little arrows on the border of the graphic
objects.

More entries appear with installation of Cenon modules. A description of these en-
tries can be found in the corresponding documentation,

3.4 The Tool-Bar

You can switch the different editing-modes of Cenon with the Tool-Bar.

Group-mode. You can move and select all the elements in this mode. You
can get to this mode from any other mode when you press the alt-key.

Rotate. In this mode you can rotate elements with the mouse. Click at some
place on a selected graphic and drag the mouse to rotate the object.

Cutter. In this mode you can split graphic objects at the position of your
mouse click.

i Sinking. In this mode you can place sinkings at the position of the mouse.
See the Sinking-Inspector in section 3.6.11 for Details.

I
219
Threads. Here you can place threads. See the Thread-Inspector in sec-
tion 3.6.3 for Details.
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&

eed Marking. In this mode you can place marks. A marking is normally used to
set a drilling.

.
'/ Line. In this mode you can draw lines. With the first click you start a line
and with every further click you set a further part of the line. With a double-click on
the left mouse-button or when you leave the mode the connection is interrupted. The
connection is also ended when the line has got no extent/dimension.

Whenever you meet the end of the element you will hear a signal.

ﬁ PolyLine. In this mode you can create poly lines. A PolyLine is like a
path composed from lines. The first click starts the PolyLine. The next clicks add
further line segments. You can end the PolyLine with a double click or by leaving
the PolyLine mode.

Whenever you hit a edge point of another graphic, a signal is played.

G Arec. The first click with the mouse sets the starting position (starting angle).
The second click defines the center and the last click defines the endpoint (end angle).

Rectangle. The first mouse-click sets/defines the first edge, the second click
the opposite edge. The rectangle is saved and worked with a polygon.

7
| Curve. The first mouse-click sets the starting position, the second the end-
point. The next two mouse-clicks set the anchor points of the curve.

Text

Text. Here you can create text. A complete text-frame is offered, that means
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you have the same editing-functions like in a rich text editor.

Tips: You can set the Font style with the Menu Format>Font. You can move the
color directly from the Color-Panel into selected text. You can copy and paste se-
lected text to other applications. You can also copy text from other applications into
your Cenon document.

Webs. Webs are used in CAM applications to keep the working piece at
its position during cutting. The webs are spared on cutting. Place the webs at good
positions around the outline of your working piece. You can adjust the width of the
webs in the Web-Inspector. For more info see section 3.6.14.

3.5 Project Settings

In this panel you can set parameter and information for your preoject. Using the
pop-up menu you can switch between the project settings and the project info.
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3.5.1 Project Info

Project Settings

10E] lonka Fleischmann

llanka Fleischmann

Airplane for 1.0 mm material

Type: Beech 17 Staggensing ( 1932]||

In the project info part you can place information regarding your project. The input
will appear at the beginning of the Cenon file, so it is also visible in a text editor.
Depending on the kind of project, the values you can enter may vary.

The following entries are the standard:

Version A place for the version number of your project
Author ‘Who did it? Name, eMail-Address etc. of the author
Copyright Who owns it?

Comments Here is a place for a descriptive text of the project

3.5.2 Project Settings

This part is not yet implemented.
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3.6 The Inspector-Panel

The inspector gives information about the selected graphic. The selected graphic can
also be changed here. You can open the inspector from the tool-menu. Depending
on the selected element the inspector changes its display appropriately.

In addition to the object parameters, the inspector is also used to manage the docu-
ment layers too.

Arc B4
OO [ren|=]

& = Background
& = Duck(Toy)

& 4= Duck(Cenon)
= o= Tert Deutsch
& = Text English
& = yhiinterservice
= = yhi-computer

Moveto Layer |
|Duck(CenDnj

Mew | Remove |

At the top of the inspector panel is an icon bar. Here you can select the kind of setting
you want to modify. You can select between object coordinates, stroke width, filling
and text. Additionally you can manage the layers of your project.

To the following inspector-types you can find further information in the following
sections. The common inspector types for width, filling, text and layers are placed at
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the end of the list:

e Arc Inspector - Section 3.6.5

e Curve Inspector - Section 3.6.1

e Crosshairs Inspector - Section 3.6.2
e Group Inspector - Section 3.6.4

e Image Inspector - Section 3.6.15

e Line Inspector - Section 3.6.6

e Mark Inspector - Section 3.6.7

e Path Inspector - Section 3.6.8

e Rectangle Inspector - Section 3.6.10
e Sinking Inspector - Section 3.6.11
e Text Inspector - Section 3.6.12

e Textpath Inspector - Section 3.6.13
e Thread Inspector - Section 3.6.3

e Web Inspector - Section 3.6.14

e Width Inspector - Section 3.6.16

e Fill Inspector - Section 3.6.17

e Texttype Inspector - Section 3.6.18

e Layer Inspector - Section 3.6.19
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e When you select more than one element of the same type you can change them
together. In this case, the inspector shows the parameters of the first selected
object.

3.6.1 The Curve Inspector

| ol =]

The curve-inspector shows information about the selected curve. The selected curve
(or more than one) can also be altered here.

Selected Point———
[447 4 >
[127 B

Here you can see and set the selected endpoint of the curve. The selected endpoint is
marked with a bigger selecting point.

133

Control Point

4>
4D

Here the control point of the selected end point of the curve is displayed and can be
changed.

Lack_|

Here you can lock the position of the curve to prevent accidently moving it. You still
can select the curve and change its parameters using the inspector.
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3.6.2 The Crosshairs Inspector

You can see the crosshairs inspector on the display when no object is selected. It
shows the position of the crosshairs that defines the zero point of all measurement as
well as output.

Crosshairs Ed
&) [ren| =
Position

E— |
[10 N

Here you can set the position of the crosshairs. For most applications this will simply
be 0/0. The coordinates of the crosshairs are an exception, because they are displayed
in absolute coordinates (relative to the lower left corner of the window).

3.6.3 The Thread Inspector

| 2170 [rl=|

The Thread-Inspector shows information about the selected thread. The selected
thread (or more than one) can be altered here, too.

The output of a thread performs a 360 degree spiral starting at the bottom of an
existing hole, and lifting the tool by the value of the pitch of the assigned tool. Note:
You have to assign a thread cutter to the layer, to get this work!

Centar — -
Ec—
Er )

Here you can see and set the position of the thread. This is it’s center point.
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FHaminal Diameter ——

| E— )

Here you can see and set the nominal diameter of the thread. This is the same as for
the srew which should fit.

Lock |
Here you can lock the position of the thread.
| Leftturn _| |

Activate this switch if you need left turned threads.

3.6.4 The Group-Inspector

=HEREE]

In the group-inspector you can find information about the selected group. The se-
lected group (or more than one) can be changed here.

Origin
EE— )
[« D

Here you can set the position of the group. The position is the lower left corner of a
rectangle enclosing the group elements.

Size
[19 -« )
.|19 - )

Here you can set the size of the group. All elements of the group will be scaled to the
new size. This operation is not without problems if the group contains text or arcs:
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e [f your group contains text, scaling may render text invisible in some rare cases.
If this happens, you have to ungroup the group and adjust the height of the text
to be visible again.

e If you set the group size arcs will be converted to curves.

Lack _|

Use this switch to fix the position of the group. The group can still be selected and
changed inside the inspector, but not handled with the mouse.

3.6.5 The Arc-Inspector

BRREE]

In the arc-inspector you can find information about the selected arc. The selected arc
(or more than one) can be altered here.

Ceanter - !
— |

In this field you can see and set the coordinates of the center of the arc.

Radius

[osee |

Here you can see and change the radius of the arc.

start Angle

E

Here you can see the starting angle. You can set/enter the starting angle from -360 to
360 degrees.

>
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Here you can see and set the angle from -360 to 360 degrees. A positive angle means
that the angle is drawn counterclockwise (positive direction mathematically).

Lack _|

Use this switch to fix the position of the arc. The arc can still be selected and edited
using the inspector, but not handled with the mouse.

Filling: You can fill an arc using the Fill-Inspector. If you fill an open arc (<360°),
two lines will be added to close the arc segment (piece of cake).

3.6.6 The Line-Inspector

D) [l

In the line-inspector you can see information about the selected line. The selected
line (or more than one) can be changed.

Start Point -
[40 \| >
|47 [ b

Here you can see and set the startpoint of the line.

Here you can set the direction of the line. Starting at the startpoint the vector heads
in the direction provided here.

Length

r— )
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The length of the line.
End Point -
|50 A

et [ D

The endpoint of the line.
Lack _|

Here you can lock the position of the line against accidently changing with the
mouse. You can still select the line and change values with the inspector.

3.6.7 The Mark-Inspector

| @Dl =

The Marking-Inspector shows the position of the selected marking. You can use a
marking for marking or for drilling.

Fositian
474

AN
VN

43

C—

The coordinate of a marking. The coordinate can be three dimensional.

=

| 3D Marker_”

Here you can select, if the marking shall be three dimensional. If you check the
switch the Z field of the coordinates is editable.

Lack _|

Here you can lock the position of the mark against accidently moving with the mouse.
You can still select the mark and change values with the inspector.
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3.6.8 The Path-Inspector

ISR RNEE

In the Path-Inspector you can find information about the selected path. You can
change the selected path (or more than one) here.

Origin ok
|e1—\| > w_;|41.2?5; \] I,
[z I D|| #6580 ~ >

Here you can set the position and the size of the path.

Selected Point———
|44? 4 >
[ 127 B>

Here you can see and set the selected point of the path. The selected point is marked
with a selecting point that is a bit bigger.

Lack_|

Use this switch to fix the position of the path. The path can still be selected and
edited using the inspector, but not handled with the mouse.

Filling: You can fill a path using the Fill-Inspector. To fill a path it needs a closed
contour. If you fill a open path, the path will be closed automatically with a line.

Tip:

e A path should not have overlapping sub-paths because otherwise the calcula-
tion of the contour can be wrong.
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3.6.9 The Polyline-Inspector

29l xS

In the Polyline-Inspector you can find coordinate information about the selected
Polyline and you can modify it.

Here you can see and set the selected point of the polyline. The selected point is
marked with a selecting point that is a bit bigger.

Use this switch to fix the position of the polyline. The polyline can still be selected
and edited using the inspector, but not handled with the mouse.

3.6.10 The Rectangle-Inspector

ol i

The Rectangle-Inspector shows information about the selected rectangle. The se-
lected rectangle (or more than one) can be changed here.

tla1275 ~

H:| 16.5808 -

Here you can set the position and the size of the rectangle.

|297. | SRR NE|
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Here you can set the width and the rotation angle from 0 to 360 degrees.

Carner Radius

E N D

Here you can set the edge-radius of the rectangle. The rectangle has got rounded
edges when the edge-radius is not 0.

Lack _|

Use this switch to fix the position of the rectangle. The rectangle can still be selected
and edited using the inspector, but not handled with the mouse.

3.6.11 The Sinking-Inspector

| 57:0] ¢ =

The Sinking-Inspector shows information about the selected sinking. The selected
sinking (or more than one) can also be changed here.

Origin
| 21 \| >
[47 A

Here you can set the position of the sinking. This is the position of the center.

Type

Hﬂ hAetric -il

This part lets you choose the type of the sinking. The main difference between the
two types is the rim. The pop up allows you to toggle between metric and inch type.
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Metrics

[{Ciistam

=i

Drilling 2 (d1):] 1.5575
Haadﬁ..(_tiz_}: [3.0339]
Head Height (£1): 07405 |

Head Brirn (12):] 0. 1055
Step Sizeif0.2117|

This area shows the metrics of the sinking. In the pop up menu you can select the
desired sinking by name. The metrics are then displayed in the fields.

Hole @ (d1) The diameter of the hole for the screw
Head @ (d2) The diameter of the head of the screw
Head height (t1) The height of the entire head of the screw including brim
Head brim (t2) The height of the head brim of the screw (only second type)
Step size This entry is used for cutting. It is the step size the cutter
increments while stepping down the cone of the head part
of the sinking.
medium fine
- 2 ——————— -t—— 3 ——— 2
| # | 1
! !
! t \ Lt
| |
! !
| f | %
| |
e dl . e dl -
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If you need to customize the settings choose Custom from the pop up menu. Then
you can modify the values in the text fields.

You can modify the names (and relating parameters) listed inside the pop up by
editing the file "Library/Cenon/System/SinkingMetrics.plist". Where Library is the
common library path (see section 5.1).

3.6.12 The Text-Inspector

o D e |

In the text-inspector you can find information about the selected text.
Crigin

[21 45

[47 A

Here you can set the position of the text box. This is the lower left corner of the box.

EE— )

Here you can set thewidth and height of the textbox.

E >

Here you can set the rotation angle of the text between 0 and 360 degrees.

Angle

| Serial Mumber _| |

With this button you can use the text as a serial number for batch production. The
trailing numbers are counted automatically. Only a Text and a TextPath can be used
as a serial number!
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| Fit harizontal _| |

When you use this button Cenon will fit in the text into the text-box. The height of
the text is preserved. Only the distance between the words and letters is reduced (the
kerning is tightened).

| Center vertical _| |

Centers the text vertically inside the text-box.
Lack_|

Use this switch to fix the position of the text. The text can still be selected and
edited, but not moved. This funxtion is especially useful to create text masks. Once
you have locked the position of a text you can still edit it, but not move. This way
you can easily create forms.

Tips:

e The color of the text can be moved with the mouse from the color-field into the
selected part of the text. so only a part of the text can be colored.

3.6.13 The Textpath-Inspector

=EEREE]

In the Textpath-Inspector you can find information about the selected Textpath. A
Textpath is a text placed on a line, polyline, arc, or curve. Depending on the object the
text is bind to, the appearance of the inspector will change and display the appropriate
kind of fields. Take a look at the line, polyline, arc or curve inspector for a description
of these fields.

See section 3.11.9 how to create a text path.

| show Patn v |
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Here you can decide whether the path the text is bound to should be displayed or not.

| Serial Mumber _| |

With this button you can use the text as a serial number for batch production. The
trailing numbers are counted automatically. Only a Text and a TextPath can be used
as a serial number!

Lack_|

Use this switch to fix the position of the text. The text can still be selected and edited,
but not moved.

3.6.14 The Web-Inspector

s [-0) (=]

In the Web-Inspector you can set the positions of webs, which should survive the
cutting of the contour of your working piece.

The working piece will not be completely separated from the material. The webs
will still connect it with the material.

Origin
| 21 \| >
[47 A

Here you can set the position of the web. This is the center of the object.

Width

)

Here you can set the size of the web. The size determines the size of the gap in the
calculated output of the paths this object sits on.

Lack_|
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Use this switch to fix the position of the web. The web can still be selected, but not
moved with the mouse.

Note:

e If you have disabled stepwise cutting in the Layer-Panel, the web remains in
the entire thickness of the material. Select stepwise cutting and provide the
thickness of the web with the final step.

3.6.15 The Image-Inspector

R REE]

The image inspector shows the parameters of the selected image. If more than one
image is selected, the parameters of the first selected image are displayed. Parameters
can be changed here, too.

Cirigin
E— )
[47 A

Here you can set the position of the image. This is the lower left corner of the image.

BiEE
Wi41.275 o s
Hlessos [ D

Here you can change the size of the image.

Mame
| Camzoootif

The name of the image.
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Compression £ Factor —

| Lz Al [+ ]

Here you can choose how to compress the image. Cenon saves images in a common
image format like TIFF to the project-file. As images especially in publishing may
become quite large, Cenon allows several compressions.

Usually Cenon will save an image in the TIFF format. You can compress TIFF
images as LZW without loosing quality. Free software sometimes doesn’t offer the
use of the LZW compression because of patent problems. The alternative is the JPEG
format. For the JPEG format you have to provide a compression factor to control how
much the image will be compressed without loosing too much quality. The less you
compress JPEG images, the better the quality. A factor of 5 is usually without visible
loss of quality.

| Thurbnail _ |

Activating this switch will create a thumbnail image of a large image. A thumbnail
is a low resolution copy (72 dpi) of an image. This small image doesn’t need much
memory compared to the repro version and saves a lot of memory and time when

working. For printing and export, the repro version of the image will be used in any
case.

Relief »/|

Here you can use the image as relief. If this switch is enabled, the output is calculated
in a special way. You find more in section ??.

The color shading of the image can be handled in one of three ways:

Linear .l|

Linear The gray levels are processed in a linear way

Circular The gray levels are processed in a way that a linear graduation
results in a circular cutting of the material.

Logarithmic The gray levels are processed logarithmic.
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Lack_|

Use this switch to fix the position of the image. The image can still be selected, but
no longer moved with the mouse.

3.6.16 The Width Inspector

O o=

The width is only available for objects which allow a border width like Line, Arc,
Curve or Path.

Stroked .i|

Here you can select, weather the object border is stroked.

Color

Here you can set the color of stroked objects. With a click on the border of the
color field the Color-Panel appears to change color. Cenon allows separate colors for
stroking and filling of objects. Here you can set the color for stroking.

Width

[o.17 QIS

Here you can set the width used to stroke the object.

”

3.6.17 The Fill-Inspector

OREREE]
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The filling is only available for objects which can be filled, like Text, Path, Polyline.

Here you can select the kind of filling you desire for the graphic object, if any at all.

The following kinds of filling are supported:

1. Simple filling in one color. The lower Arc is filled with a different color.

2. Linear color shading: The shading starts with a start color towards an end color
using the given step width. The lower Arc is filled with bigger steps.

3. Radial Shading: This shading starts from a center of the object.

4. Axial Shading: This shading starts on one side of the object and goes in axial
direction. This kind of filling is a little tricky to adjust to achieve the desired
results. The example was build using 6 Arcs with different centers and angles.

Here you set the color or start color of the selected graphic object. If you have
selected more than one object, then the color of the first selected object is displayed.
With a click on the border of the color well, the Color-Panel appears, where you can
change the color.
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If the border of the color well is white, then the color selected in the Color-Panel will
be set directly. If the border is not selected, you can drag and drop a color from the
Color-Panel into the color well.

—— Graduate Color ——

Here you can set the end color of the selected object. With a click on the border of
the field you get the Color-Panel to change the color.

Graduate Angle

ol

V

Here you can set the direction of the shading.

Radial Center

For radial shading, you can move the knob inside the square to determine the center
of the filling. The square symbolizes the bounding box of the graphic object.

‘ Stepwidth | 5 \|>‘

Here you can set the stepwidth of the color shading. The stepwidth is also used on
export. If you create documents for printing a smaller step width might be better as
the default.

3.6.18 The Texttype-Inspector

Textl-al_ﬁ’ Text §| ‘

This part of the inspector is only available for text and textpath objects.
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Font Size

Wd)‘

Here you can set the font size for the entire textbox. If you want to change the text
size for a selected range of characters only, you can use the Font-Panel (section 3.3.3)
to do so.

Line Height

Wd)‘

Here you can set the line height for the entire text box. If you want to change the line
height for a selected range of characters only, you can use the text ruler (section 3.3.3)
to do so.

3.6.19 The Layer-Inspector

| Dl =]

At this place inside the Inspector-Panel you find the layer management of Cenon.
Here you can add, rename, reorder and remove document layers.

& .= Background
& = Duck(Toy)
& 4= Duck(Cenon)
= = Text Deutsch
& = Text English

& .= vhiinterservice

This part lists all the layers of your document. Here you can select and reorder layers.

& = By clicking on the eyes you can switch on and off the display of a layer.
A layer with closed eye will neither be displayed nor printed or exported. A layer
which is not displayed can’t be edited too.

7 - By clicking the pencil you can decide, if a layer is editable or not. A layer
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with broken pencil can’t be edited. This can be used to protect your layer from
accidental modifications.

The layers in the list can be reordered by dragging them to the new position in the
list while the Control-Key on the keyboard is pressed.

hove to Layer I

This button moves the selected objects of your document to the selected layer in the
layer list. Therefor all participating layers must be visible and editable! None of the
graphic objects should be locked.

| |Duck(Cennnj |

Here you can change the name of the selected layer in the list. Press the Enter key to
set the new name.

‘ My I Remove | ‘

With these buttons you can add and remove layers.

Mew | Hemwel

Here you can create a new layer or delete/erase a selected layer.

3.7 Transform-Panel

With the Transform-Panel you can transform selected graphic objects. The Transform-
Panel is called from the Menu Tools > Transform-Panel.

With the pop-up menu you can select the different kinds of transform operations
explained below. The transform operations usally work upon the selected objects.
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3.7.1 Scaling

In this part of the Transform-Panel you can scale objects in x and y direction. Select
the switch to keep the aspect ratio of the objects. That means that the scaling is
carried out with the same value in x- and y-direction.

You enter the percentage of the scale into the fields. For example when you enter e.g.
110 the graphic is enlarged to 110 % of the original size (that means 10 % bigger).

As soon as you click on Set the scaling is carried out.
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3.7.2 Moving

Transfonm

You can move the selected graphic objects relative or absolute.

Move Relative The entered coordinates are added to the position of the ob-
jects. Negative coordinates move in the negative directuion of
the coordinate system (e.g. x = -10 moves to the left, x = 10
moves to the right).

Move Absolut The entered coordinates are set directly for all selected objects.
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3.7.3 Rotation

Here you can rotate the selected objects. The angle is given in degrees. Positive
values rotate counter clock wise.

3.7.4 Align

Transform

Using this part of the Transform-Panel allows you to align graphic objects in several
ways. You have to select at least two objects to be able to align them. The icons
show quite clear what will happen.
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Activating the switch *Align layers’, you can align complete layers instead of single
objects. This works as follows:

e Select at least one graphic object on each layer. These are the reference objects
for aligning the layers.

For each layer, the smallest rectangle enclosing the reference objects is used to
align the layers. If you want to center layers you want to select all objects on
the layers. However, if you want to align dedicated objects on the layers above
each other, then you only want to select a single object on each layer.

e One layer will not be moved and plays the role of the reference layer. If you
want to give this role to a layer, make the layer not editable (see section 3.6.19).
All other layers will be aligned to this one. If all layers are editable, the last
one is used as reference layer.

3.7.5 Mix
Transform x|
| il
__|mixLayers

Locked Ohjects ——

" dont mix
€ don’t mix layers

Pl

Here you can mix the positions of graphic objects in several ways. This can be used
to produce unique samples of an art work e.g. a collection of engraved signatures.
This way you can add additional value to a product without having much work.
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If you select the switch you can mix objects across layers. Otherwise each layer is
mixed on its own.

The radio buttons decide how to process fixed objects. You can keep them where
they are or keep them on their layer.

3.8 Intersection-Panel

Intersection Panel E{

Creates ahjects at
intersections of
selected graphics

" Drill Marks

(" Threarts

" Sinkings

" frcs _

 webs

The Intersection-Panel is used to distribute objects of differend kind upon intersec-
tion points. For example if you have to drill holes in a concentric pattern, you can
easily construct the pattern using arcs and lines. Now you can use this panel to place
drill markings on each intersection.

You can use Lines, Arcs, Curves, and Paths to create the intersections.

" Drill Marks

(" Threads

" Sinkings

" &rcs

Here you can select the kind of object you want to create. The objects will be placed

on each intersection using default values for all parameters. Use the appropriate
Inspector-Panel (see section 3.6) to change these values to whatever you like.

Place objects of selected kind upon each intersection on editable layers.
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3.9 Batch Production

The panel for batch production (Tools>Batch Production) is for the production of
multiple duplicates. The working surface of the engraving machine is used optimally
to distribute the available graphic as often as possible on the surface. So you can
create the same object several times without making a copy of the objects or without
having to justify the starting point of the machine again.

Here you can set the distance between the individual parts of the duplicate.

In this part of the panel you can set how the duplicates are distributed. In the pop up
you can select between distribution based on the "Number of Items" or the "Size of
Material". In the two fields you can specify your choice.
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Set

After a click on "Set" the duplicate is generated. The duplicates are generated for
all layers which are enabled for batch production (see Layer-Details in section ?7?).
In our example you can see four duplicates. On the lower left side you can see
the original graphic. The display shows only the frame of the three duplicates. It’s
possible to give every part in batch production its own serial number. Therefore
choose the appropriate entry in the Text-Inspector (see section 3.6.13). On every part
the serial number is increased by one automatically.

Copy |

When you use Copy, Cenon creates real copies of your graphic. This needs more
memory and you have to maintain all copies of the graphic! The copies are dis-
tributed like duplicates on the working area. Using copy you can edit the single
copies of the graphic.

Rermove |

Click on remove to remove the duplicates for batch production that has been gener-
ated (This makes no sense and doesn’t work for real copies!).
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3.10 The Graphic Window

After you have loaded or created a new document it is displayed in the (following)
graphic window.

[m] ExampleAMP.cenon — ..n/DTP/Docu/UserGuide/English/imagesfGraphiciWindow ]

|

% (95,6028 | W[ e0.7917 | Width] 520028 |Height | 10,2306 | nim =

il
[

. 00e)

The crosshairs mark the zero point of coordinates. If the grid is enabled, it is aligned
to the crosshairs too.

For CAM applications, the grey frame represents the machine table. So you can
easily see if the graphic is not too big for the working area.

#: [ 191.205 | ¥ [59.9722 | Width:[ 191205 | Height

Here you can see the display of the coordinates. On the left you can see the absolute
position to zero; on the right you can see position relative to the last mouse-click.
When you create a new object you can see its size on the right.

Here you can choose the measuring unit of the display of the coordinates.
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& -] 1o 4 4]

With these elements you can zoom the graphic. In the pop-up-menu you can choose
a new zooming-factor. With the buttons + and - you can zoom into and out of the
graphic. With the magnifying glass you can create a rectangle. Then the content of
the rectangle is displayed on/over the whole screen.

Tips:

e When you press the Alt-key the operation is carried out in one direction only.
So you can move the graphic only in x- or y-direction. The same goes for
rotating.

e With the Shift-key you can select or deselect further graphic objects.

3.11 Editing

e Lines

e Rectangles
e Curves

e Arcs

e Images

e Paths

e Polylines
o Text

e Textpaths

e Groups
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e Markings
e Threads
e Sinkings
e Webs

You can modify the graphic objects as follows:

Selecting

Click on the graphic object to select it. If you press the Shift-key during this opera-
tion, you can select or deselect additional objects.

If you keep the mouse-button pressed, you can drag up a rectangle around objects.
All objects which are partly inside the rectangle become selected. If you press the
right Alt key while dragging the rectangle, only those objects are selected which are
completely inside the rectangle.

The edit-menu offers additional ways to select graphic objects:
e Use Edit> Select Color to select all objects which have the same color as the
already selected objects.

e Use Edit> Select Equal to select all object which are of the same kind as the
already selected objects.

e Use Edit> Select All to select all objects.

Moving

Click on the graphic object. Keep the mouse-button pressed to move the object. It
doesn’t matter whether the graphic object is selected or not - as long as you don’t hit
a knob.
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If you want to move an entire object but want to grap it at a vertex point (where
the knobs are placed), pay attention that the object is not selected when starting the
move. This way you can move the object by snapping the grabbed point to the grid or
other object points. The distance where objects are catched, can be set in the general
preferences (see section 3.1.1). This feature is very helpful whenever you have to
attach graphics to each other.

Dragging points

To drag an end point or an anchor point (vertex) of an object you must select it first.
Then you can move the vertex by keeping the mouse-button pressed (drag). When
this point meets another point during the operation you can hear a signal, and the
point is snapped to this point. You can set the distance to which points are snapped
in the Preferences-Panel.

Copy/Cut/Paste

You can copy a selected object with the entry "copy" (menu) into the intern buffer.
It’s also possible to move it to the buffer by cutting it out. Objects that are in the buffer
you can insert in the position of the mouse with the command "paste". When you
want to insert more than one copy of an object, the copied objects appear staggered to
each other. After you have inserted the second object you can move it. Every further
object is inserted with the same distance like the distance between the original object
and the first copy (smart paste).

Delete

You can delete a selected object with the delete entry in the menu (Edit->Delete) or
with the backspace-key.
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Tips:

e When you press the right Alt-key the action is carried out in one direction only
(either x- or y-direction).

e To be able to edit an object the Move-Mode must be active (see Tool-Bar sec-
tion 3.4). You can get to the Move-Mode from any other mode while pressing
the Alt-key.

3.11.1 Editing Lines

Create

a

To create a Line you have to activate the line mode.

e The first mouse-click sets the starting point the second the end point.
e After a line has been finished the next line starts from the end point of the last.

e The creation of the lines can be stopped with a double-click on the end point
of the line or by setting the endpoint on an existing point. You can also end
a line by setting the endpoint at an illegal coordinate or by clicking outside of
the window. In this case the line is not set.

e When you press the Alt-key only one line is drawn or it is stopped after the
next segment.
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Selecting

Click on the line to select it. The end points of the selected line are marked with
knobs. The selected end point is displayed bigger than the other one.

Tips:

e When you press the Alt-key moving of the line or its end points is carried out
in one direction only.

3.11.2 [Editing Rectangles

2! o
L3 |
Create

To create a Rectangle you must activate the rectangle mode.

e The first mouse-click sets a vertex, the second the opposite vertex.

e During the creation the mouse-position locks to the points near to it.
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Selecting

Click on the border of the rectangle to select it. A selected rectangle is displayed
with knobs on each edge point.

3.11.3 Editing Curves

To edit curves mind the following:

Create

¢

To create a curve you have to activate the curve-mode.

e The first mouse-click sets the starting point, the second sets the endpoint of the
curve. The third and the fourth mouse-click set the anchor points.

e After you have finished the curve, the next curve starts at the endpoint of the
previous curve.

e You can end the drawing of the curve with a double-click on the endpoint or
when you set the endpoint on an existing point. You can also end a curve by
setting an illegal coordinate or by clicking outside of the window. In this case
the curve is not set.
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e If you keep the alt-key pressed only one curve is drawn or is stopped after the
next segment.

e During the generating the mouse-position locks to the points near to it.

Selecting

Click on a curve to select it. The end point and the anchor points are marked differ-
ently. The selected end point (on the left) is displayed bigger than the others.
Moving

If you move an endpoint the corresponding anchor point is moved with it.
Tip:

o If you keep the alt-key pressed the curve is only dragged/shifted/moved in one
direction.

3.11.4 Editing Arcs
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Create

e The first mouse-click sets the starting point, the second sets the center and the
third sets the endpoint.

To create an arc you have to switch to the arc-mode.

e During the generating of the Arc the mouse position locks to the points near to
it.

Selecting

Click on the arc to select it. You can see the starting point, the endpoint and the
center. The selected endpoint is bigger than the others.

Moving

You can move the arc by clicking on the center or the frame and by keeping the
mouse-button pressed.

Dragging the starting point and endpoint
You can move the starting point and the endpoint (a)round the center. So you can

transform the starting and the end angle. If you keep the Ctrl-key pressed you can
also alter the radius.

Tips:

e By pressing the alt-key the arc can only be moved in one direction. When you
move the arc by clicking on the center the alt-key doesn’t work.
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3.11.5 Editing Images

Create

Images can be imported to Cenon by Drag and Drop or via Copy and Paste. Addition-
ally you can import images via the menu (File > Import...). So, many possibilities.

Exposing

You can expose an image by clipping it from a Path, Polyline, Rectangle or Arc. To
do this first create the path describing the desired contour of the image. Then select
both image and path and join the two objects using the menu (Edit> Join).

Selecting

To select an image click on it. The selection is displayed by four knobs at the corners
of the image. This is also true for exposed images.



128 CHAPTER 3. REFERENCE PART - THE FUNCTIONS OF CENON

Moving

You can move the image by dragging it with pressed mouse button.

Resize

You can drag the four corner points of the image to change the size of the image.

If you press the right Alt key while moving the corner point of an image, the image
will keep its natural aspect ratio.

Tip:
e If you press the right Alt key while moving an image, the movement will be

limited in one direction only. If you press the right Alt key while moving a
corner point (resize), the image keeps its aspect ratio.

3.11.6 Editing Paths

A Path consists of Lines, Arcs and Curves. A filled path has always got a closed
outline. An unfilled path can be open. A path can consist of several parts that don’t
have to be connected with each other (Sub Paths). After you have filled a Path all the
independent parts are closed. A Path is filled EOR (exclusively or) that means that
areas outside of the outline are left blank.
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Create

You can create a Path by uniting several objects. You can generate a path out of
Lines, Arcs, Curves and Paths that exist already. Use the Join item in the Edit menu
to create a path (EditrJoin).

Additionally you can create a path from other objects. For example you can build the
contour of an object (see section 3.12), or by flattening a text (Kapitel 3.3.3).

Splitting

You can split a path with the Split command in the Edit menu (Edit> Split).

Selecting

Click on the path to select it. All points of the selected path are marked with a knob.
When a path is open and not filled the selected endpoint is displayed bigger than the
others.

Moving

You can move the path by clicking on the border of the path and keeping the mouse-
button pressed as you move. If you want to grab a corner point of the path to move it
(for example to attach it to other objects or snap it to the grid), the path must not be
selected before starting the move.

Moving points in the Path

The selected points of a Path can be moved with the mouse. Just press the mouse
button on a knob of the Path and drag it to the new position.
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Tip:

e When you keep the right Alt key pressed the path or a point is moved only in
one direction.

3.11.7 Editing Polylines

0 1

A Polyline is very similar to a path with the difference that a polyline contains lines
only. A Polyline can be open or closed.

The advantage of using a polyline is, that it is managed very efficiently which makes
the Polyline faster and the size of your project much smaller.

Create

/on

Selecting

To create a polyline, you have to activate the Polyline mode in the Tool-Bar.

A Polyline can be selected by clicking on it. The corner points of the Polyline will
be marked by knobs.
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Moving

You can move the polyline by clicking on it and moving it while you keep the mouse
button pressed. If you want to move the Polyline by grabbing it at a corner point be
sure that the Polyline is not selected. This way you can attach the Polyline to other
objects or snap it to the grid with the grabbed point.

Moving corner points

The selected points of a Polyline can be moved with the mouse. Just press the mouse
button on a knob of the Polyine and drag it to the new position.

3.11.8 Editing Text

Cenon
s Modular Design «

and Production
Software

=] =1 =]

Create

Text

Select the text button from the Tool-Bar.

1. The first mouse click sets the position of the text.

2. Now you can start writing the text.
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Selecting

Click on the text to select it. The text-frame of the selected text is marked by 8 knobs.

Moving

Click on the text-frame to move it. You can move it by keeping the mouse-button
pressed (drag).

Resizing the text box

You can change the size of the text-box by dragging one of the eight buttons to a new
position.

Editing

You can edit the text with a double-click within the text-frame in the usual way.
When the text-mode is active you only have to click once to edit the text.

|=]|[orPt =1/=% =a|=a| [r* (o
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When you edit text a ruler appears on top of the Graphic-Window. In the ruler you
can set the text attributes of the selected part of the text (Alignment, line distance,
Tabulators).

You can change the font by using the Font-Panel. You can get it with the menu item
Format > Font > Font-Panel.

You can change the color of selected parts of the text by using the Color-Panel. You
can get it with the menu item Tools > Colors.
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Tips:

e When you keep the Alt-key pressed the moving of the text-box is only carried
out in one direction.

3.11.9 Textpfade editieren

Creating

1. Select a text and a path element (line, arc, curve)

2. Now select the menu item Format > Text > Bind To Path

Splitting

To split a Textpath into its components, select the menu entry Edit> Split.

Selecting

Click on the path of the Textpath to select it. The path element of the selected
Textpath is marked by knobs.
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Moving

You move a textpath the same way as you would move the path it is bind to. See the
description of the used path element (Line, Polyline, Arc, Curve) to read more about
how to move the Textpath.

Editing

You can edit the text of the Textpath with a double-click on the path element. This
brings the text in a unrotated position, so you can easily edit it. When you’re done
with editing the text, press on the Arrow in the Tool-Bar.

3.11.10 Editing Groups

A group consists of several objects grouped together in one object.

Creating

You can create a Group by grouping several selected objects. You can group almost
everything. Use the Group item in the Edit menu to create a group (Edit> Group).

Ungroup

You can split a group with the Ungroup command in the Edit menu (Edit> Ungroup).

Selecting

Click on a group to select it. The buttons of all united graphic objects are displayed.
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Tip:

e When you keep the Alt-key pressed the group can only be moved in one direc-
tion.

3.11.11 Editing Marks

In a CAM application a mark is usually used to mark drillings. But that’s not the
only way to use a mark. Basically a mark is a single point in your document.

Creating

To create a marking you have to switch in the marking-mode. You set a
marking with a mouse-click.

Selecting

Click on the mark to select it. The center of the selected marking is marked with a
knob and its position is displayed in the inspector.

Tips:

e When you keep the right Alt key pressed the moving is only carried out in one
direction.

3.11.12 Editing Threads

Usually a thread is used to cut a thread in an already existing hole or cylinder. You
can create inside and outside threads.
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Creating

&

To create a thread you have to switch in the thread-mode. You set a thread

with a mouse-click.

1.

Decide whether you want to create an inside or outside thread. Create a hole
for an inside thread, or a cylinder for an outside thread. The dimensions of the
hole depend on the data of the thread cutter you use. See the data sheet of the
tool.

In the Layer-Panel create a layer for the thread.

. In the Layer-Panel set the tool-radius correction of the layer according to the

kind of thread you need: Inside correction = inside thread, Outside correction
= outside thread. (see section ?7?)

In the Layer-Panel assign a thread cutter to the layer (see section 2?).

. In the Tool-Bar change to the thread-mode (see section 3.4), then set the thread

with a click to the desired position.

Set the nominal diameter of the thread in the Thread-Inspector (see section 3.6.3).
The nominal diameter is the diameter the screw diameter got its name from.
For example: M6 for a 6 mm screw and thread. You have to enter 6 (if the unit
of Cenon is set to mm).

Selecting

Click on the thread to select it. The center of the selected thread is marked with a
knob and its position is displayed in the inspector.

Tips:

e When you keep the right Alt key pressed the moving is only carried out in one

direction.
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3.12 Konturen erzeugen

With the menu Edit>"Build Contour’, you can create the contour of a selected
graphic object. In the Contour-Panel which appears, you can set the distance of
the contour to the graphic object. The result will be a Path , which resembles the
contour of the object.

Contour: X

Di stance:l 1

Set

In this panel you can enter the distance of the new contour to the previous object-
contour. The distance can be negative. That means the new contour is inside the
object contour. When you click on Set every selected object is transformed into
a Path that is bigger or smaller than the original object (depending on the chosen
distance).

When the distance is too big this might create unwanted overlappings. You can
remove them by hand.

Vectorizing

You also can build a contour of an image. This would be called a vectorization. To
achieve good results, the image should be monochrome and available in high enough
resolution.
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3.13 Color Separation

To prepare your document for exposition and pre-press, you have to separate the
document into the four basic colors cyan, magenta, yellow, and black. Therefor four
films respective files will be generated.
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The selected paper size (here AS landscape) will be surrounded by crop marks and
descriptive text. These make it possible to identify the filmes and precisely stack
together the four separate colors for printing.

The color separation of Cenon is integrated into the Print-Panel. Use the menu
Print... to open the Panel.

This buttons allow to activate the color separation process.

ﬂl To generate files click on the save button of the Print-Panel. A file selec-
tion panel will appear where you can set the destination and name of the files to write.
The files will be written with the name extended by some characters specifying the
color (_c=cyan, _m=magenta, _y=yellow, _k=Dblack).

Use the Print button to send the separated colors directly to a printer or
type setter.

Note: To get the desired page layout on color separation, be sure to set your working
area to the same size as the page layout (see section 3.3.3).
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Chapter 4

Device Configuration

4.1 General Information

The configuration files of Cenon are ASCII files containing all the information needed
for the definition of devices and import formats.

This section will describe how to configure Cenon for the different "dialects" of
Gerber, HPGL as well as for your own XYZ-units and controller. Although Cenon
comes with a number of predefines configuration files (*.dev), there is a chance that
the commands of one or the other program is not understood properly or that there
is no 100% matching configuration file available for your controller or device. Un-
fortunately, there are slight differences in the command set of the different programs
and controllers.

4.1.1 Creating your own configuration files

In case you do not find a suitable configuration file for you purpose in one of the
device directories (HPGL, DXF, xyz etc.), you can alter an existing file.

e Start a text editor.

141
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e Load an already existing configuration file (extension: *.dev). Only load files
from the appropriate directory and save them in the same directory after mod-
ification. This is very important, because Cenon uses the directory name for
accessing the right file format. The setup directory names, for these reasons,
should not be changed. Therefore, a Gerber configuration file should only be
placed in the directory Gerber, etc.

e To avoid duplication of work you should load a configuration file which matches
the command set of your computer the most. You can change the configuration
file to your needs using the information provided in the output device manual.

e After changing all necessary entries you have to save the file (to the same
directory under a new name) and quit the text editor.

e [oad from within Cenon the newly created file (Menu: Info > Preferences) and
you are ready to start.

4.1.2 Important Notes

e The comments before the number sign (here: controller) are not important for
the program (comment here: device name). These can be changed to your
needs or even deleted. Cenon is recognizing only the characters from the num-
ber sign to the end of the line (here: "CNC750"). Example:

controller #CNC “CNC750"”

e The entries are not permitted to exceed more than one line.

e The order of the entries is not important, unless there are several entries with
the same #-code. You also can delete an entry if it is not necessary.

e Within a command line you can add after a backslash () certain sequences to
the code. You could for example, write in a new line each single command in
the output file:
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\n Neue Zeile (Zeilenvorschub)

\e Escape-Sequenz

\r Carriage Return (Wagenriicklauf)
\" Anfiihrungszeichen

e If you have to leave space for variable parameters, which will be provided by
Cenon. This is done with a percent sign (%) followed by a letter:

%ot will accept a floating value (with decimal values entries). The
output format can be regulated with these entries. Examples:
%.0f  ->1
%.2f  ->1.00
%2.2f ->01.00
%2f ->01

%d is describing decimal integers

Tox is describing hexadecimal values

%ld is describing decimal long integers

%oe is describing numbers with exponents

e Transmitted commands are always in quoted and also contain the appropriate
variable (e.g. pen selection for a HPGL-Plotter:

select pen #PEN "SP%d; "

e Parameter providing information to Cenon (e.g. number of pens for HPGL-
plotter or the size of the working area) are not quoted:

number of pens #NPN 8

e If several values are passed on to the program in one command line, these
values have to be separated by at least one space (e.g. maximum working area
of a unit):

X Y Z-maximum range (mm) #SIZ 380 235 63
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4.2 Gerber-Import/ Export

4.2.1 General Information

For importing Gerber-files there is besides the differences in the command set also
the problem of choosing the appropriate aperture table for the output. This glitch is
solved in the new extended Gerber format. But first some general information about
Gerber-Photo-plotter.

The Gerber-file-format is well know and has been in use for a long time to create
high quality film layouts with photo-plotters. More and more this is done with laser
plotter which can interpret the PostScript format. But to better understand the Gerber
file format let us go back to the times, when the computer aided printed circuit board
development was in its early stages. Earlier plotters with very large casings were
used, which used a regular bulb for film exposure. To achieve different conductor
path widths and different shapes of soldering points, the plotters were equipped with
a shutter unit with different aperture sizes. Depending which aperture was placed in
front of the light bulb, different conductor path widths and soldering points could be
simulated.

A so called D-code was used to tell the photo plotter which aperture to use. Each D-
code is representing a particular aperture on the shutter unit. Because these shutter
units were restricted in size, only a limited number of apertures were available and
therefore, only a limited number of D-code possibilities were available. For modern
units, this problem does not exist, because mechanical apertures are replaced by
apertures simulated electronically.

Each time a printed circuit board is exported by your CAD-application through a
Gerber file, a file with all the circuit board data will be created. This file contains
the necessary D-code information. Therefore, for each path the appropriate aperture
indicates the width of the conductor path and the style of the soldering point. All
this information is stored in the aperture table. Because your PCB manufacturer
uses this table for setting up his photoplot unit for producing the board he needs this
information. While importing the file for engraving the insulating path to the Cenon
application, Cenon is actually using this file to simulate the photo plotter.
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Some CAD applications have the drawback of using dotted lines for the representa-
tion of soldering point instead of using the appropriate flash command. This results
in very large Gerber files which result in extremely long calculation times and unsat-
isfactory results. Try in these case a PostScript output or change the application.

Most of these problems are solved with the new extended Gerber format (RS274X).

4.2.2 Export of Gerber files

The export of Gerber files is not critical. Cenon always writes the extended Gerber
format, so no paramaters have to be set.

4.2.3 Import of Gerber files

For importing Extended Gerber files just click on the file.

For importing standard Gerber files you need, besides the Gerber file an Aperture
table file.

e Aperture-Tabelle (Extension *.tab)

The folder Devices/gerber contains a default aperture table with the name of the .dev
file. While importing the Gerber file this table will automatically be loaded, unless
there is a specific aperture table with the specific project name in the project folder.
In this case, the appropriate project aperture table has priority and will be loaded.

Unfortunately, there is no standardization for creating an aperture table. Therefore,
you have to prepare the table of your CAD-system usually with a text editor so that
Cenon can use it.

To make the task of adjusting the aperture table or adopting your CAD application
format easier, we will explain the single entries in the following sections, so that you
can make the necessary changes.
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4.2.4 Commands in the configuration file

device name #DEV "Gerber"
This describes the name of the unit. The name can be up to 20 characters long and
the name selection is your choice. At appropriate places within Cenon this name will
be used for display.

resolution in points/inch #RES 1000

Preset resolution for the output of the file in points per inch.

tool #ITO "D"
tool #IT1 "DX"

These two code segments contain code to select the appropriate aperture. The second
value is optional.

X #IXp "X"
Y #IYP "Y"

Code for a x- or y coordinate.

I #I11P "IV
#IJP HJH

Code for the relative translation of a x- or y-coordinate.

draw #IDR "D1"
Code to switch on the light (comparable to the pendown command for plotter) with
which the film in Gerber plotters can be exposed. In contrast to the flash command,

the light stays on during the whole movement of the photo plotters and can be used
for conductor paths.
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move #IMO "D2"

Movement to new position with the light switch off (comparable to pen-up).

flash #IFS "D3"

Flash light for marking a soldering point.

circle cw #ICI "G75*G0O2"

Command for drawing a circle clockwise.

arc #IAR "G75"

Command for drawing an arc (-segment) clockwise.

terminator #ITR "*"

Termination sign for ending the command sequence.

absolute #ABS "GOoO"
relative #REL "Go1"

The coordinates can be forwarded either as absolute (in reference to a fixed origin)
or relative (in reference to the last position) values.
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4.2.5 The Aperture Table

This file is only need for standard Gerber. If you use the Extended Gerber format
(RS274X) you can skip this section.

tool, type (L=trace/line, P=flash/pad, A=both), width, height (mill

This is the decription at the beginning of the aperture table. It is important to follow
the order in which the entries are placed in each line:

e The D-code (aperture number) of a specific tool is placed directly after #DCD

e This is followed by a character, describing the tool type (aperture). As char-
acters are possible: L for lines (trace/line), P for point (flash/pad) and A for
both.

e Next entry is the tool width in mil (1/1000 inch).
e Thereafter, the entry for height, also in mill.

e Last, the shape has to be entered. As possibilities you have C for circle or R
for rectangle.

The complete aperture table has to be build in this way, so that Cenon can use the
file. If your CAD application is able to create the aperture files in this way, you will
have it very easy. In this case you only have to name the file and assure that the file
has the extension *.tab. If this file will be used as standard aperture table, save it in
the Devices/Gerber folder with the name Gerber.tab. If it is used for a certain project,
save it in the appropriate folder with the filename and the extension *.tab.

After saving the file you can load it when needed. If for some reasons your CAD-
program is not able to produce such a matching file you are required to make changes
by hand. The following two lines give you an example of part of a manually altered
aperture file table:

line 0.1 mm #DCD "D10*" L 4 4 C
pad 0.5 #DCD "D39*"™ P 20 20 C
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4.3 DXF-Import/ Export

4.3.1 General Information on DXF

DXF is an abbreviation for "Drawing Exchange Format" and became mostly known
through the application AutoCAD. Not only AutoCAD, but other CAD applications
use this file format mainly to exchange technical drawings. Because DXF-files can
be imported from Cenon directly (in contrary to HPGL-files) we will not elaborate
on this format and would rather guide you to the DXF specifications for download
from http://www.autodesk.com

4.3.2 Export von DXF-Daten

Fiir die Ausgabe konnen Sie in den Voreinstellungen von Cenon angeben, ob Text
zerlegt werden soll. Ansonsten gibt es hier keinen Freiraum.

4.3.3 Import von DXF-Dateien
For the DXF import there isn’t much to adjust. Important is the correct setting of the

measurement unit for the file which you want to import. You can set this resolution
in the Import part of the Preferences-Panel.

When writing a DXF file from a CAD application, be sure to set the drawing extends
so that your entire drawing is inside.

4.3.4 List of supported DXF syntax

Interpreted Table Entries:

e LAYER
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150 CHAPTER 4. DEVICE CONFIGURATION

Implemented Graphic Elements (2D):

e ARC

e INSERT

o LINE

e LWPOLYLINE
e MTEXT

e POLYLINE

e SOLID

e TEXT

e VERTEX

4.4 HPGL-Import/ Export

4.4.1 General Information

The HPGL- format is an established and well known language to control pen plotters
of any kind. The quality and the speed of the import process is depending on the file
created by your program. If for example, every line in file is created with one line
thickness, a thick line has to be created from several thin lines during the converting
process. We may experience the same problem drawing a circle. In this case a circle
will be composed from many smaller line pieces, which is a very time consuming
process and will not provide best results. In general it is not advisable to use HPGL
files for calculating insulation paths.

HPGL is not the best choice for the calculation of outlines or filled areas. Filled
areas are represented in HPGL by many parallel lines. In these cases Cenon will have
difficulties calculating the milling path. You should export HPGL-files therefore in
the most simplest way (without filled areas, overlapping areas or thick lines etc.).
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4.4.2 Export of HPGL files

The export generates a standard HPGL file, where not much can be tuned.

4.4.3 Import of HPGL files

The import is unsing the entries provided by the configuration file.

4.4.4 Commands in the configuration file

device name #DEV "HP 7550"
This describes the name of the unit used and serves only information purposes.
resolution in points/inch #RES 1021

This value indicates the plotter selected resolution of the output file in points per
inch.

number of pens #NPN 8
Describes the number of pens, which will be used for the output file.
1. pen width (unit: 1/1000 mm) #PWI 250

This describes the pen width in units of 1/1000. For a thickness of 0.25mm a value
of #PWI 250 has to be entered. For each pen width there is a separate line. If for
example the field number has an entry of 8 you have to have eight different entries
for the different pens. This is true even when the width of all eight pens is the same.
The first entry always stands for the first pen.
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1. pen color (0 - 1000, rgb) #PCO 1000 0 O

Plotters are in most cases equipped with several pens of different colors. Because the
color can not be entered directly with HPGL (in contrary to PostScript) the color in-
formation has to be determined indirectly by using different pen colors. For each pen
the color intensity for red, green and blue can be entered separately. From this color
information, color for each pen in the preview window of Cenon will be composed.

special characters in command strings:

\n linefeed

\e escape

\r carriage return

\” quotation marks

parameters will be inserted at %f (%d, %x, %1d, %e)

Please refer for the different parameter values to general information in section 4.1.2.
draw #DRW "PD"

Pen down command for drawing of lines etc.
pen #IPN "V

Selection of the actual pen
move #MOV "PU"

This command is used for moving the pen to a certain position without drawing.

absolute #ABS "PA"
relative #REL "PR"
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The coordinates can be forwarded to the output device either as absolute (in reference
to a fixed origin) or relative (in reference to the last position) values.

circle (radius) #ICI "CI"
Command for drawing a circle.

arc absolute (xm,ym,arc angle) #IAA "AA"
Command for drawing an arc in relation to the origin.

arc relative (xm,ym,arc angle) #IAR "AR"
Command for drawing an arc in relation to the last position of the pen.

terminating characters #ITR ";\n\z"

All possible characters for termininating a command sequence.

4.5 PostScript-Import / Export

4.5.1 General Information to PostScript

PostScript is the industry standard of the publishing industry and the most popular
graphic format. In contrary to bitmap graphics, where images are composed of single
points, vector graphic images are composed from lines, circles, curves, rectangles,
etc., where closed paths can be filled with a color. This information will be sent
to a output device. There, the information will be converted to the printed image.
Since printing is done, after all, point by point, an interpreter will convert the vector
information to point information.
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For Imagesetter, PostScript is the industry standard for a long time. All graphic
information is contained in one single file. Further external files to handle any output
are not necessary. If your application of choice is capable of creating PostScript
output files we strongly recommend to use this option. In this case it is not necessary
to enable special settings for importing PostScript files.

Depending on the system, PostScript is imported using varying interpreters. For
OpenStep the Display-PostScript of the system is used. For Apple and Linux, the
GhostScript interpreter has to be installed, which is usually the case on Linux sys-
tems, but not on Apple.

4.6 PDF-Import

The Portable Document Format is imported with the help of Ghostscript, provided
that you have installed GhostScript.

4.7 DIN-Import

4.7.1 General Information

DIN files correspond to the DIN 66025 norm. Most of the drill data files can be
imported using this device.

Currently device configurations for the Excellon (excellon.dev), and the Sieb&Meyer
formats (sm1000.dev, sm3000.dev) are supplied. Additional configuration files can
be created.

Usually you want to modify the resolution entries only. This can be necessary, be-
cause some programs on the market use non standard resolutions for exporting files.
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4.7.2 Commands in the configuration file

device name #DEV "Excellon 2000"

This describes the name of the unit. The name can be up to 20 characters long and
the name selection is your choice. At appropriate places within Cenon this name will
be used for display.

resolution in points/inch #RES 10000

Preset resolution for the output of the file in points per inch. Here 10000 points/inch.
This is what you usually want to change.

resolution (mm) in points/inch #RMM 25400

Preset resolution if set to mm (usually using M71). Here 25400 points/inch. This
information is used in the Excellon format only. The Sieb&Meyer format has a fixed
resolution.

start #IST "%%3000"

This specifies a string to recognize the file format. In the exampe the Sieb&Meyer
3000 format is introduced.

parameter #IPA "3"
The supplied string introduces the parameter section of the Sieb&Meyer formats.
select tool #ITL "T"

The commant to select a tool (usually "T").
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X #IXp "X"

Y #IYP "Y"
The strings introducing the x-, and y-coordinate.

terminator #ITM "\n"

The string specifying the end of a command. In the example this is a usual line feed
(\n).

The device files contain additional commands which are not important or not ment
for modification.
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Appendix

5.1 Files and directories

5.1.1 Cenon program

The program file of Cenon is located in the application directory of your computer
system:

Apple: /Applications/Cenon.app
GNUstep: /usr/GNUstep/Local/Applications/Cenon.app
OpenStep: /LocalApps/Cenon.app

5.1.2 Library

In the Library path of Cenon you can find examples, projects and all the things which
are intended to be customized (configurations, data files, etc.). Cenon has a global
Library path shared between al users, which is not writable to a user, and a local
Library path inside the home directory (here HOME) of the user:

157
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Apple: /Library/Cenon
HOME/Library/Cenon

GNUstep: /usr/GNUstep/Local/Library/Cenon
HOME/GNUstep/Library/Cenon

OpenStep: /LocalLibrary/Cenon
HOME/Library/Cenon

Files can appear in both Library paths (the global libarry path and the home library
path). In this case the file in the home library path has priority. This allows a user to
modify a configuration file without changing the installation of Cenon.

In the following we describe the most important files and directories. All located in
the HOME-Library of Cenon:

‘ File / Folder ‘ Description ‘
Projects Your Cenon projects and examples
Examples Some examples of import formats
Devices/din/*.dev Configuration files for the drill data import

Devices/gerber/*.dev | Configuration files for the Gerber import
Devices/hpgl/*.dev | Configuration files for the HPGL import

Devices/xyz/*.dev The device configuration files

CAM Folder for special configurations
CAM/Jobs Your CAM projects and example projects
CAM/positions ASCII file holding the position memory
CAM/magazine ASCII file holding the tool magazine

Cenon provides two folders for projects (Projects and CAM-Jobs). There is no tech-
nical differences between the file format.

5.1.3 Cenon Modules

Cenon Module konnen an verschiedenen Stellen im Dateisystem abgelegt werden.
Der Ort ist abhéngig vom eingesetzten Betriebssystem:



5.2. ERROR AND WARNING MESSAGES 159

Apple: /Library/Extensions/Cenon
HEIM/Library/Extensions/Cenon
HEIM/Library/Cenon

GNUstep: /usr/GNUstep/Local/Library/Bundles/Cenon
HEIM/GNUstep/Library/Bundles/Cenon
HEIM/GNUstep/Library/Cenon

OpenStep: /LocalLibrary/Bundles/Cenon
HEIM/Library/Bundles/Cenon
HEIM/Library/Cenon

5.2 Error and Warning Messages

e Select two objects for joining!

You have to select two objects to be able to join them and create a path object.

e Can’t create backup file. File not saved!
Check if you have write permission to the directory and the Cenon file you
tried to write.

e Could not open file FILENAME.

Check the read permissions on the file FILENAME, and on the directory it is
located in. You need read permissions on a file to open it. Another possibility
is that the file is corrupted or of a format Cenon is not capable to read. Check
for other messages in the Console.

e Could not open file FILENAME. Using Default.

Here Cenon tells you that it can’t read FILENAME, and uses default values
instead.
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You have unsaved documents!

If you quit Cenon and have unsaved documents, this message appears to give
you a chance to save the files. You can review the unsaved files or quit anyway.
Can’t write file.

Check the write permissions on the directory you try to save in. Also check if
there already is a file which you are not allowed to overwrite.

FILENAME has changes. Save ?

This warning message appears if you try to close a window of a document
which hasn’t been saved yet. You have the choice to save the file or close it
anyway.

Do you want to revert to: FILENAME ?

This is a safety message giving you a chance to cancel your request to reload a
file and loose all your changes.

This Operation will force a recalculation of the graphic!

Cenon gives you a chance to cancel the operation or will start a recalculation.

This Operation can take a while!

You are warned that the following operation will take some time and you have
to wait until has been finished. This message does not appear in expert mode.

The contour will be calculated know! You may want to stop this operation
to calculate on a later time.

You are warned that the output tracks needs recalculation and you are given
a chance to calculate them on a later time. This message does not appear in
expert mode.

Layer LAYERNAME needs recalculation!

If you start the output and the output tracks of some layers are not calculated
yet, Cenon gives you a chance to cancel and take a look at the tracks before
you start output. Otherwise the output is calculated and executed directly.
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¢ No data to process!
You started the output without any data to process.

e Couldn’t locate tool name TOOLNAME in magazine! You may have re-
moved the tool since your last session.

You have tools assigned to a layer of your job which is not in the active mag-
azine. Check the magazines for the needed tool or select a new tool from the
pop up menu.

e Name 'NAME’ allready in use!
If you add or rename a layer or position this message can appear. You should
rename the existing layer or choose a different name for the new one if possi-
ble.

¢ You need to install the Cenon Library!
Some Library files are missing. On OpenStep the Library of Cenon has an
extra package. Most likely you haven’t installed it.

e Only one layer of this kind allowed!
Cenon allows only one layer of the kinds: Fitting-Layer, Clipping-Layer, or
Levelling-Layer.

e Only one position for parking allowed!
This shouldn’t happen at all, but somhow you tried to add a second layer for
the parking positiong. This is not possible.

e Only a single rectangle allowed on leveling layer!
You created graphic objects on the leveling layer which are not allowed there.
Delete everything but a single rectangle.

e This Operation will remove the fill layer attached to the Pick Out!

The Pick-Out owns a second layer. If you leave the correction for a Pick-Out
this layer is removed.
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e Automatic adjust! Be sure to have placed the surface sensor correctly,
before pressing ’Start’.

If your machine allows automatic measuring of the tool offset, this message
gives you a chance to place the switch under the tool before it starts the opera-
tion.

e Do you really want to remove the current magazin?
A warning message telling you that you are about to remove an entire maga-
zine.

e Set Magazin: This operation will remove all tools from layers!

A warning message telling you that you have to assign a new tool to all your
layers, if you select a new magazine. You have the chance to cancel your
request.

e Stop work?

A warning message. It appears when you click on Stop while the output is
running. The Z axis is lifted and you have a chance to check things, before you
continue or stop the output.

e Graphic out of range!

Your graphic is located outside of the machine table. Be sure that the graphic
you want to process is completely inside the gray lines, representing the ma-
chine table. You have a chance to continue, but this can lead to an incomplete
output of your graphic.

e Please log in as root!

Licensing only works as user root.

More messages can appear in the Console window (or system log file). Especially
messages during calculation of the output path are listed there.

On Linux this file can be found in the menu of the Window Manager under Info >
System Console. On OpenStep it can be found in Tools> Console of the Workspace
Manager.



5.3. KEYBOARD COMMANDS

5.3 Keyboard Commands

Editing, Selecting

The keys Alt, Shift, and Ctrl can be used in combination with the mouse. The mean-
ing of these combinations can be found in the description of each mouse action. See

section 3.11.

Menu keys:

On Apple you have to use the Apple-Key instead of the Alt key !

Command | Key word | Description

Alt-a all Select all

Alt-A Area Show Working Area panel

Alt-b bold Change selected text to bold
Alt-B Batch Batch Production

Alt-c copy Copy selected objects into buffer
Alt-C Color Show Color-Panel

Alt-d direction | Revert direction

Alt-D Direction | Display directions of objects
Alt-e equal Select equal objects

Alt-F Form Show Transform-Panel

Alt-g group Group selected objects

Alt-G unGroup | Ungroup selected groups

Alt-h hide Hide program

Alt-i iltalic Change selected text to italic
Alt-1 Inspector | Show Inspector-Panel

Alt-j join Join selected objects

Alt-J unJoin Split joined objects (Path, Textpath, clipped Image)
Alt-m mirror Mirror selected objects

Alt-M Moves Show output tracks
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Alt-n new Create new document

Alt-o open Open (Load) document

Alt-O Optimize | Optimize moves

Alt-p print Print document

Alt-P Page Show Page-Layout panel

Alt-q quit Quit program

Alt-r rotate Rotate selected objects by 90°

Alt-R Ruler Toggle text ruler

Alt-s save Save document

Alt-S Save as Save document with new name

Alt-t text Show Font-Panel

Alt-T Tool Display tool diameter

Alt-u unsave Revert to saved document

Alt-U pUnch Punch selected objects

Alt-v view Paste buffer into document

Alt-w window | Close window

Alt-x Cut selected objects into buffer

Alt-z Undo

Alt-Z Redo

Alt-? ? Help

Alt-1 Graphic-Inspector, when editing text: Copy ruler
Alt-2 Width-Inspector, when editing text: Paste ruler
Alt-3 Fill-Inspector, when editing text: Copy font
Alt-4 Texttype-Inspector, when editing text: Paste font
Alt-5 Layer-Inspector

Alt-8 Bring to front

Alt-( Bring one object further to the front

Alt-9 Send to back

Alt-) Send one object further to the back

Alt-# Toggle grid

Alt-Shift-# Show Grid Panel

Alt-< align text to the left
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Alt— center text
Alt-> align text to the right

5.4 Frequently asked Questions

For an up-to-date version of the questions and answers visit the internet pages of
Cenon www.Cenon.info.

5.4.1 Import
The imported DXF graphic is displayed in a wrong size

Go to the preferences of Cenon to change the unit of the DXF import. The DXF
format has no defined unit, that’s why you have to tell the importing program the
unit of the file.

The size of imported fonts is not correct

You can tell the exporting program to flatten all text to a path.

If you are using HPGL or DXEF, the cause is that no font information is inside the file,
so Cenon will use the default font.

If you are using PostScript, it is possible that the desired font is not installed on your
system. In the latter case you can install the font as Type 1 font. Ask the documenta-
tion of your computer system on how to do this or ask your system administrator for
help.


www.Cenon.info
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Graphics which are generated using Freehand contain intersecting lines
In Freehand don’t use the output option Split Complex Paths. Otherwise Freehand

splits large paths into several smaller paths to limit the complexity of generated
PostScript files.

I can’t import HPGL files

The extension of HPGL files must be .hpgl, or .plt. The case (lower case) is important
on Unix systems!

5.4.2 Computer System

A double click on a file opens the file in the text editor and not in Cenon

Select the file in the File Viewer of the Workspace. Then go to the Tool Inspector

(Pop Up Menu Tools) of the Workspace (not Cenon), and move the Cenon symbol to
the left. Doing this you set Cenon as default application for the selected file type.

After a check for disks, no disk symbol appears in the shelf of the File Viewer

Disks are not displayed when their file name is missing or not appropriate. You can
find your Disk in the root directory (/).

Transport of Cenon files to DOS disks

Before you can copy a Cenon file to a DOS disk, you have to truncate the file ex-
tension (.cenon) to 3 characters (.cen). To use the file you have to change back the
extension to .cenon.

If possible, you should use Unix or Apple formatted disks to transport files.
The prefered way to transfer files is a LAN (Ethernet).
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Killing a process

If it happens that you have a process hanging around as a zombi, you can kill this
process.

On OpenStep go to the process list of the Workspace using the menus *Tools - Pro-
cesses’. If you have to kill Cenon, you must kill the output process (controller) too.

5.5 Glossary

"What does this mean?" is sometimes the question. This glossary should help you to
better understand technical terms and also give you a short explanation to important
terms from A (aperture table) to Z (Cenon). If more information is available in the
manual we will refer to the appropriate section of the manual.

Aperture Table An aperture table is necessary for importing Gerber
files. This file contains all the necessary D-code in-
formation to assign the aperture of the photo-plotter
(soldering point shape, sizes and conductor path thick-
ness) to the different layout elements of your CAD-
program. The aperture table used for export has to be
used for importing as well. The extended Gerber for-
mat doesn’t need an aperture table any more.

Blow Up Special kind of isolation tracks for producing PCB pro-
totypes. A blow up is used to increase the isolation
paths for easier soldering.

CNC-Controller The CNC controller is the link between your computer
unit and the engraving unit. The controller converts
the signals send by Cenon to signals of higher electri-
cal current, so that they are able to power the different
axes of the engraving unit.
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Configuration file

Conical

Inlay

Excellon Format

Extended Gerber

Gerber-Format

HPGL

Inner Contour
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In your configuration file (extension .dev) control com-
mands and other parameter for the output device are
defined or different commands of the different import
formats are translated for Cenon.Default A default is
an entry preset by an application.

Conical describes a shape which goes from wide to
narrow.

Inlays are a special case of cutting material, so that one
poarts fits exactly into another.

Excellon is a data format used by industrial drilling
machines for drilling holes in circuit boards. Many of
the CAD programs can export these data and enable
you to import all the drilling information. The format
is imported using the DIN import.

This is an improved Gerber format without the need
of a separated Aperture file. The format also allows
complex ground planes, which is very important for a
clean import of the data.

Gerber is a data format for exporting layout data. In
general, photo-plotter use this file format. Because
this file format is very common, most of the CAD-
programs are able to create files in this format.

This abbreviation is an acronym for "Hewlett Packard
Graphics Language" and is one of the well know and
mostly used command set for accessing pen plotter.

The inner contour is mainly used for calculating the
engraving path of filled areas. The appropriate tool is
labeled engraving tool.
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Isolationsgravur

Konfigurationsdatei

Outer Contour

Outline-Algorithm

Pick-Out

PostScript

Project

Rub-Out
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Spezielle Art der Werkzeugradiuskorrektur zum Er-
stellen von Leiterplatten-Prototypen. Die Isolations-
gravur graviert die Isolationen um die Leiterbahnen.

In einer Konfigurationsdatei (Extension .dev) werden
Steuerungsbefehle und weitere Parameter fiir das Aus-
gabegerit definiert oder die Befehle der verschiedenen
Importformate fiir Cenon iibersetzt

The calculation of the outer contour of components is
necessary, if the elements have to be cut-out totally
and the cut out should comply exactly with the layout
of the element. These cut-outs are normally done with
a milling tool.

The outline-algorithm is responsible for creating a con-
tour around graphic objects.

The pick out is a special method of creating output for
detailed engraving purposes. It is used with a conical
tool.

PostScript is a vector based page description, which is
mainly used in the DTP area. This format is normally
used to drive photo-type-setters to create inexpensive
film layouts.

A project in Cenon is your document file. It is saved
with the extension ’.cenon’. In CAM applications a
Cenon project can also be called a job.

Rub-Out area (especially PCB prototyping) indicates
areas were analog to the chemical process the conduc-
tion copper material is completely removed (important
for HF-applications). The actual tool diameter is used
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for calculation of the appropriate path to completely
remove all the copper.

Sieb & Meyer Sieb & Meyer ist ein industrielles Bohrdatenformat.
Die beiden Sieb & Meyer Formate (1000 und 3000)
konnen mit dem DIN Import importiert werden.

Spindle Also called HF- or SF-spindle. Using high frequent
three-phase current, extremely high revolutions per minute
(RPM) can be generated, to achieve a precise output
and a high feeding speed.

Cenon Universal construction and production software.
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Align Text (Menu entries), 79
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Arc-Inspector, 93

Arcs (Editing), 125

Astro-Panel (Menu entry), 83
Axial Filling (Fill-Inspector), 106

Batch production, 115

Batch Production (Menu entry), 82

Batch production (Text-Inspector), 100,
102

Bring To Front (Menu entry), 80

Build Contour, 137

Build Contour (Menu entry), 76

CAM-Panel (Menu entry), 83
Center vertical (Text-Inspector), 101
Circular (Image-Inspector), 104
Color (Width-Inspector), 105

Color Separation, 62, 138

Color shading (Fill-Inspector), 106
Colors (Menu entry), 82
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Colors to layers (Import), 67
Configuration files, 141

Console, 162

Convert To Path (Menu entry), 80
Coordinates (Graphic window), 118
Copy (Editing), 121

Copy (Menu entry), 75

Create a new document, 29

Create Layers, 33

Crosshairs (Graphic window), 118
Crosshairs-Inspector, 91
Curve-Inspektor, 90

Curves (Editing), 124

Curves to Arcs, 67

Cut (Editing), 121

Cut (Menu entry), 75

Delete (Menu entry), 76

Delete objects (Editing), 121
DIN, 25, 69

DIN (Preferences), 67
DIN-Import (Configuration), 154
Direction (Line-Inspector), 94
Directories, 157

Disable caching (Preferences), 65
Display (Menu), 71

Dock, 22
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Document (Menu), 71

Dragging points (Editing), 121
DXE, 25, 69

DXF (Preferences), 67
DXF-Import (Configuration), 149

Edit Menu), 71, 75

Editing, 119

End Color (Fill-Inspector), 107
Error messages, 159

Excellon, 69

Excellon (Preferences), 67
Expert mode (Preferences), 65
Export (Preferences), 68
Export (Save-As Menu), 74
exposing images (Editing), 127
Extensions, 24

FAQ, 24, 165

Features, 11

Features (CAM), 13

Files, 157

Fill Angle (Fill-Inspector), 107
Fill Center (Fill-Inspector), 107
Fill Color (Fill-Inspector), 106
Fill-Inspector, 105

Fit horicontal (Text-Inspector), 101
Flatten text (Export), 68

Flatten text (Import), 67

Font (Menu), 78

Font size (Texttype-Inspector), 108
Font-Panel (Editing text), 132
Format (Menu), 71, 78

General (Preferences), 64
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Gerber, 25, 69

Gerber (Preferences), 67
Gerber-Export (Configuration), 144
Gerber-Import (Configuration), 144
GhostScript (Konfiguration), 154
Gitter-Panel, 80

Graduate Angle (Fill-Inspector), 107
Graphic window, 118

Grid, 32

Grid (Menu entry), 80

Group (Menu entry), 77

Group Inspector, 92

Groups (Editing), 134

Gruppe Ungroup (Menu entry), 77

help layer, 35

Hidden Areas, 76

Hide (Menu), 72

History, 10

HPGL, 24, 69

HPGL (Preferences), 66
HPGL-Import (Configuration), 150

IMlustrator, 25
Image-Inspector, 103
Images, 52

Images (Editing), 127
Import, 69

Import (Menu entry), 72
Import (Preferences), 66
Import ASCII (Menu), 72
Info (Menu), 71
Inspector (Menu entry), 82
Installation, 19
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Layer list (Layer-Inspector), 108
Layer-Inspector, 108

Layers (Inspector-Panel), 88

Left Turn (Thread-Inspector), 92
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Library, 157

Line height (Texttype-Inspector), 108
Line-Inspector, 94

Linear (Image-Inspector), 104
Lines (Editing), 122

Logarithmic (Image-Inspector), 104

Mailing list, 24

Mark (Editing), 135
Mark-Inspector, 95

Menu keys, 163

Menus, 70

Messages, 159

Mirror (Menu entry), 77
Mix (Transform-Panel), 113
Modules (Directories), 158
Moving (Editing), 120
Moving (Transform-Panel), 111

New (Menu entry), 72
New Document, 30
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Nominal Diameter (Thread), 92

Open (Menu entry), 72
Optimize Moves (Menu entry), 81

Page Layout, 81

Pages (Inspector-Panel), 88
Parameter file, 66

Paste (Editing), 121

Paste (Menu entry), 76
Path-Inspector, 96

Paths (Editing), 128

PDF, 25

PDF-Import (Configuration), 154
Plug-Ins (Directories), 158
Polyline (Editing), 130
Polyline-Inspector, 97
PostScript, 25, 69

PostScript (Preferences), 67
PostScript-Import (Configuration), 153
Preferences, 63

Preparations, 29

Print (Menu), 71

Printing, 62

Project-Info (Menu entry), 83
Project-Settings (Menu entry), 83
Publishing, 27

Punch (Menu entry), 76

Questions (FAQ), 165
Quit (Menu), 72

Radial Filling (Fill-Inspektor), 106
Rectangle-Inspector, 97
Rectangles (Editing), 123
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Redo (Menu entry), 76

Relief (Image-Inspector), 104
Remove Backups (Preferences), 65
Remove objects (Editing), 121
Resize images (Editing), 128
Resolution (DXF import), 67
Revert to saved (Menu entry), 75
Rotate (Menu entry), 77

Rotation (Transform-Panel), 112
Ruler (Editing text), 132

Save As (Menu entry), 74

Save Document, 31

Save Output (Menu entry), 75

Scaling (Transform-Panel), 110

Select All (Menu entry), 77

Select Color (Menu entry), 77

Select Equal (Menu entry), 77

Select non editable layers (Preferences),
65

Selecting (Editing), 120

Send To Back (Menu entry), 81

Serialnumber (Text-Inspector), 100

Serialnumber (Textpath-Inspector), 102

Show path (Textpath-Inspector), 101

Show Ruler (Menu entry), 79

Sieb&Meyer (Preferences), 67

Sieb&Meyer 1000, 69

Sieb&Meyer 3000, 69

Sinking-Inspector, 98

Smart Paste, 121

Snap to point (Preferences), 64

Speichern (Menueintrag), 74

Split (Menu entry), 76

INDEX

Start Color (Fill-Inspector), 106
Start Point (Line-Inspector), 94
Step width (Fill-Inspector), 107
Strength (Width-Inspector), 105
Stroke width (Width-Inspector), 105
Support, 23

Teach-In-Panel (Menu entry), 83
Text (Editing), 131

Text (Menu), 79

Text Ruler (Menu entries), 79
Text to paths (Import), 67
Text-Inspector, 100
Textpath-Inspector, 101

Textpfade editieren, 133
Texttype-Inspector, 107
Thread-Inspector, 91

Threads (Editing), 135

Thumbnail (Image-Inspektor), 104
Tools (Menu entry), 82

Tools (Menu), 71
Transform-Panel, 109
Transform-Panel (Menu entry), 82
Tutorial, 27

Undo (Menu entry), 76
Unit (Preferences), 65
USB adaptor, 21

Vectorizing (Build contour), 137

Warning messages, 159
Web-Inspector, 102
Width, 105
Width-Inspector, 105
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Windows (Menu), 71
Working Area, 81
Working area, 31
WWW, 24

Zoom (Graphic window), 119
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